Network card isolated from network

Kernels & Hardware, configuring network, installing services

Network card isolated from network

Postby odesport » 2017-03-23 07:49

Hello,

I'm trying to install Debian 8 on a DELL M620 Blade. 8 network cards are detected by the OS. I can configure eth0 and eth1 with bonding, vlan and bridge. But when I configure eth2 with a vlan I can't see other hosts on the network. It worked perfectly on Debian. What can I check ?

/etc/network/interfaces

Code: Select all
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual
        post-up ethtool -K eth0 rx off

auto eth1
iface eth1 inet manual
        post-up ethtool -K eth1 rx off

auto bond0
iface bond0 inet manual
        slaves eth0 eth1
        bond_miimon 100
        bond_mode 1

auto bond0.49
iface bond0.49 inet manual
        vlan_raw_device bond0


auto vmbr0
iface vmbr0 inet static
        address 172.20.1.68
        netmask 255.255.255.192
        gateway 172.20.1.126
        bridge_ports bond0.49
        bridge_stp off
        bridge_fd 0

auto eth2
iface eth2 inet manual
        post-up /sbin/ifconfig eth2 mtu 9216

auto eth2.96
iface eth2.96 inet static
        vlan_raw_device eth2
        address 192.168.20.7
        netmask 255.255.255.0
        post-up /sbin/ifconfig eth2.96 mtu 9216


/proc/net/vlan/config

Code: Select all
VLAN Dev name    | VLAN ID
Name-Type: VLAN_NAME_TYPE_RAW_PLUS_VID_NO_PAD
eth0.49        | 49  | eth0
eth2.96        | 96  | eth2


lsmod | grep 8021q
Code: Select all
8021q                  25264  1 bonding
garp                    7153  1 8021q
odesport
 
Posts: 1
Joined: 2017-03-23 07:34

Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable