Debian 9 stretch with SiS 671/771

Kernels & Hardware, configuring network, installing services

Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 08:51

User of Ubuntu since 09.04 version on a laptop with SiS671 video chip I have succeeded in each upgrade until 16.04 to get a nice 1280x800 resolution.
I have just moved to Debian 9 Stretch and get only a 1024x768 resolution as my laptop uses the "vesa" driver.

I made several false attempts to install a good driver and reported these attempts with a lot of errors in my reports, reason why I deleted many of them and kept only those which can help.

Please see below.
Last edited by jcglt on 2017-04-04 02:45, edited 5 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby peter_irich » 2017-04-01 10:07

I have not SISxxx video card. Xorg must work and without /etc/X11/xorg.conf.
xorg.conf it is needed only if Xorg not works without it.
1st check are the libraries installed: libgl1-mesa-dri, libgl1-mesa-glx, libxcb1-dri2-0.
Perhaps, Debian 9 not supports SiS. Driver xserver-xorg-video-sis is exist in Debian Wheezy only.
If xserver-xorg-video-all is installed, X serevr must work if only with vesa.

Peter.
peter_irich
 
Posts: 1195
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 19:47

With Ubuntu, everytime I upgraded I faced the same problem : my system worked with a "vesa" driver with a resolution of 1024x768 and I had to add SiS drivers and an Worg.file to get a 1280x800 resolution. These drivers were 9 years ago SIS671 and now sisimedia work on Ubuntu16.04-2.
I read in this forum that people have got the same result with Debian Jessie : viewtopic.php?f=6&t=120734
I guess I should get the same result with Stretch even if it was not planned when 9 was released, I have copied sisimedia 64-bit drivers in my system and I just have to tweak my configuration.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 19:49

By the way, as I'm new in this forum, how can I wrap very long files in a rolling box ?
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby GarryRicketson » 2017-04-01 19:54

User avatar
GarryRicketson
 
Posts: 4460
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 20:53

Thanks Garry. I amended the first post of this thread. It has become far easier to read. Used to Ubuntu forum I did not know how to do with yours and I must appologize for my rude behaviour.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 21:27

Deleted
Last edited by jcglt on 2017-04-04 02:45, edited 2 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 21:51

Deleted
Last edited by jcglt on 2017-04-04 02:46, edited 2 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-01 22:15

Deleted
Last edited by jcglt on 2017-04-04 02:46, edited 2 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-02 22:28

Deleted
Last edited by jcglt on 2017-04-04 02:47, edited 2 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-02 23:06

Deleted
Last edited by jcglt on 2017-04-04 02:47, edited 2 times in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby peter_irich » 2017-04-03 05:21

Your chipset is SIS671, but it is not present in the supported chipsets list in Xorg.log.0, the nearest is SIS670.
I don't is this sis module suitable for SIS670.

Peter.
peter_irich
 
Posts: 1195
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

New thread : Debian 9 Stretch with SiS671/771

Postby jcglt » 2017-04-03 08:56

Shifting from Ubuntu 16.04 to Debian 9 Stretch on a laptop with SiS671 I was not surprised to face the same problems I had faced with this SiS671 to get a 1280x800 resolution.
I downloaded the last driver (built in January of 2017) x11-driver-video-sis_0.10.9-2_amd64 from a RPM server and converted it with alien to .deb format.
I ran #dpkg -i x11-driver.....deb which stored a sis_drv.so file in /usr/lib64/xorg/modules/drivers/ and copied it in /usr/lib/xorg/modules/drivers/
Starting the computer in recovery mode I ran #Xorg -configure which stored a xorg.conf.new file in /root/
I ran #X -config /xorg.conf.new and the system blocked.

The /usr/shate/X11/xorg.conf.d folder holds 4 files :

10-amdgpu.conf
Code: Select all
Section "OutputClass"
   Identifier "AMDgpu"
   MatchDriver "amdgpu"
   Driver "amdgpu"
EndSection


10-quirks.conf
Code: Select all
# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
# http://bugs.freedesktop.org/show_bug.cgi?id=22442
Section "InputClass"
        Identifier "ThinkPad HDAPS accelerometer blacklist"
        MatchProduct "ThinkPad HDAPS accelerometer data"
        Option "Ignore" "on"
EndSection

# https://bugzilla.redhat.com/show_bug.cgi?id=523914
# Mouse does not move in PV Xen guest
# Explicitly tell evdev to not ignore the absolute axes.
Section "InputClass"
        Identifier "Xen Virtual Pointer axis blacklist"
        MatchProduct "Xen Virtual Pointer"
        Option "IgnoreAbsoluteAxes" "off"
        Option "IgnoreRelativeAxes" "off"
EndSection

# https://bugs.freedesktop.org/show_bug.cgi?id=55867
# Bug 55867 - Doesn't know how to tag XI_TRACKBALL
Section "InputClass"
        Identifier "Tag trackballs as XI_TRACKBALL"
        MatchProduct "trackball"
        MatchDriver "evdev"
        Option "TypeName" "TRACKBALL"
EndSection

# https://bugs.freedesktop.org/show_bug.cgi?id=62831
# Bug 62831 - Mionix Naos 5000 mouse detected incorrectly
Section "InputClass"
        Identifier "Tag Mionix Naos 5000 mouse XI_MOUSE"
        MatchProduct "La-VIEW Technology Naos 5000 Mouse"
        MatchDriver "evdev"
        Option "TypeName" "MOUSE"
EndSection


40-libinput.conf
Code: Select all
# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection


70-wacom.conf
Code: Select all
# Some of the below input classes appear 3x times, once for each of
# "tablet", "touchscreen", and "touchpad" to ensure that the Wacom
# driver is not accidentally bound to other types of hardware that
# Wacom has made which are not handled by the wacom driver (e.g the
# Wacom Bluetooth Keyboard)
#
# https://sourceforge.net/p/linuxwacom/bugs/294/

Section "InputClass"
        Identifier "Wacom USB tablet class"
        MatchUSBID "056a:*"
        MatchDevicePath "/dev/input/event*"
        MatchIsTablet "true"
        Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom USB touchscreen class"
        MatchUSBID "056a:*"
        MatchDevicePath "/dev/input/event*"
        MatchIsTouchscreen "true"
        Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom USB touchpad class"
        MatchUSBID "056a:*"
        MatchDevicePath "/dev/input/event*"
        MatchIsTouchpad "true"
        Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom tablet class"
   MatchProduct "Wacom|WACOM|PTK-540WL|ISD-V4"
   MatchDevicePath "/dev/input/event*"
   MatchIsTablet "true"
   Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom touchscreen class"
   MatchProduct "Wacom|WACOM|PTK-540WL|ISD-V4"
   MatchDevicePath "/dev/input/event*"
   MatchIsTouchscreen "true"
   Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom touchpad class"
   MatchProduct "Wacom|WACOM|PTK-540WL|ISD-V4"
   MatchDevicePath "/dev/input/event*"
   MatchIsTouchpad "true"
   Driver "wacom"
EndSection

# Serial Wacom devices should always be one of tablet, touchscreen, or
# touchpad so we can safely get away with just one match section in
# these cases
Section "InputClass"
        Identifier "Wacom PnP device class"
        MatchPnPID "WACf*|WCOM*|WACM*|FUJ02e5|FUJ02e7|FUJ02e9"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom serial class"
   MatchProduct "Serial Wacom Tablet"
   Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom serial class identifiers"
        MatchProduct "WACf|FUJ02e5|FUJ02e7|FUJ02e9"
        Driver "wacom"
EndSection

# Hanwang tablets
Section "InputClass"
   Identifier "Hanwang class"
   MatchProduct "Hanwang"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection

# Waltop tablets
Section "InputClass"
   Identifier "Waltop class"
   MatchProduct "WALTOP"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection

# N-Trig Duosense Electromagnetic Digitizer
Section "InputClass"
   Identifier "Wacom N-Trig class"
   MatchProduct "HID 1b96:0001|N-Trig Pen|N-Trig DuoSense"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
   Option "Button2" "3"
EndSection


First xorg.conf.new file tested :
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "PageFlip"              # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "DoubleShadow"          # [<bool>]
   Identifier  "Card0"
   Driver      "modesetting"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



/var/log/Xorg.0.log.old file found after this test :
Code: Select all
[    85.668]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    85.668] X Protocol Version 11, Revision 0
[    85.668] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[    85.669] Current Operating System: Linux debian 4.9.0-2-amd64 #1 SMP Debian 4.9.13-1 (2017-02-27) x86_64
[    85.669] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-2-amd64 root=UUID=af045728-655c-42d2-b64a-dd011dde3c94 ro single
[    85.669] Build Date: 03 March 2017  03:14:41PM
[    85.669] xorg-server 2:1.19.2-1 (https://www.debian.org/support)
[    85.669] Current version of pixman: 0.34.0
[    85.669]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    85.669] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    85.670] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  3 17:34:58 2017
[    85.670] (++) Using config file: "/root/xorg.conf.new"
[    85.670] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    85.670] (==) ServerLayout "X.org Configured"
[    85.670] (**) |-->Screen "Screen0" (0)
[    85.670] (**) |   |-->Monitor "Monitor0"
[    85.671] (**) |   |-->Device "Card0"
[    85.671] (**) |-->Input Device "Mouse0"
[    85.671] (**) |-->Input Device "Keyboard0"
[    85.671] (==) Automatically adding devices
[    85.671] (==) Automatically enabling devices
[    85.671] (==) Automatically adding GPU devices
[    85.671] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    85.671] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    85.671]    Entry deleted from font path.
[    85.671] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    85.671]    Entry deleted from font path.
[    85.671] (**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[    85.671] (**) ModulePath set to "/usr/lib/xorg/modules"
[    85.671] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    85.671] (WW) Disabling Mouse0
[    85.671] (WW) Disabling Keyboard0
[    85.671] (II) Loader magic: 0x55d482e96e00
[    85.671] (II) Module ABI versions:
[    85.671]    X.Org ANSI C Emulation: 0.4
[    85.671]    X.Org Video Driver: 23.0
[    85.671]    X.Org XInput driver : 24.1
[    85.671]    X.Org Server Extension : 10.0
[    85.671] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
[    85.671] (--) using VT number 2

[    85.671] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    85.672] (--) PCI:*(0:1:0:0) 1039:6351:14c0:003a rev 16, Mem @ 0xc0000000/268435456, 0xd4000000/131072, I/O @ 0x00009000/128, BIOS @ 0x????????/131072
[    85.672] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    85.672] (II) LoadModule: "glx"
[    85.672] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    85.780] (II) Module glx: vendor="X.Org Foundation"
[    85.780]    compiled for 1.19.2, module version = 1.0.0
[    85.780]    ABI class: X.Org Server Extension, version 10.0
[    85.780] (II) LoadModule: "modesetting"
[    85.780] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    85.780] (II) Module modesetting: vendor="X.Org Foundation"
[    85.780]    compiled for 1.19.2, module version = 1.19.2
[    85.780]    Module class: X.Org Video Driver
[    85.780]    ABI class: X.Org Video Driver, version 23.0
[    85.780] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    85.781] (EE) open /dev/dri/card0: No such file or directory
[    85.781] (WW) Falling back to old probe method for modesetting
[    85.782] (EE) open /dev/dri/card0: No such file or directory
[    85.782] (EE) Screen 0 deleted because of no matching config section.
[    85.782] (II) UnloadModule: "modesetting"
[    85.782] (EE) Device(s) detected, but none match those in the config file.
[    85.782] (EE)
Fatal server error:
[    85.782] (EE) no screens found(EE)
[    85.782] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    85.782] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    85.782] (EE)
[    85.783] (EE) Server terminated with error (1). Closing log file.


I replaced "modsetting" by "sis" in the xorg.conf.new file and ran again #X -config /root/xorg.conf.new
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "PageFlip"              # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "DoubleShadow"          # [<bool>]
   Identifier  "Card0"
   Driver      "sis"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


and the system blocked with the following /var/log/Xorg.0.log file :
Code: Select all
[    29.241]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    29.241] X Protocol Version 11, Revision 0
[    29.242] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[    29.242] Current Operating System: Linux debian 4.9.0-2-amd64 #1 SMP Debian 4.9.13-1 (2017-02-27) x86_64
[    29.242] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-2-amd64 root=UUID=af045728-655c-42d2-b64a-dd011dde3c94 ro single
[    29.242] Build Date: 03 March 2017  03:14:41PM
[    29.242] xorg-server 2:1.19.2-1 (https://www.debian.org/support)
[    29.242] Current version of pixman: 0.34.0
[    29.242]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    29.242] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    29.243] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  3 20:20:10 2017
[    29.316] (++) Using config file: "/root/xorg.conf.new"
[    29.316] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    29.372] (==) ServerLayout "X.org Configured"
[    29.372] (**) |-->Screen "Screen0" (0)
[    29.372] (**) |   |-->Monitor "Monitor0"
[    29.372] (**) |   |-->Device "Card0"
[    29.372] (**) |-->Input Device "Mouse0"
[    29.372] (**) |-->Input Device "Keyboard0"
[    29.372] (==) Automatically adding devices
[    29.372] (==) Automatically enabling devices
[    29.372] (==) Automatically adding GPU devices
[    29.394] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    29.454] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    29.454]    Entry deleted from font path.
[    29.454] (**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[    29.454] (**) ModulePath set to "/usr/lib/xorg/modules"
[    29.454] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    29.454] (WW) Disabling Mouse0
[    29.454] (WW) Disabling Keyboard0
[    29.454] (II) Loader magic: 0x55dec1984e00
[    29.454] (II) Module ABI versions:
[    29.454]    X.Org ANSI C Emulation: 0.4
[    29.454]    X.Org Video Driver: 23.0
[    29.454]    X.Org XInput driver : 24.1
[    29.454]    X.Org Server Extension : 10.0
[    29.454] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
[    29.454] (--) using VT number 2

[    29.454] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    29.455] (--) PCI:*(0:1:0:0) 1039:6351:14c0:003a rev 16, Mem @ 0xc0000000/268435456, 0xd4000000/131072, I/O @ 0x00009000/128, BIOS @ 0x????????/131072
[    29.455] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    29.455] (II) LoadModule: "glx"
[    29.483] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    29.612] (II) Module glx: vendor="X.Org Foundation"
[    29.612]    compiled for 1.19.2, module version = 1.0.0
[    29.612]    ABI class: X.Org Server Extension, version 10.0
[    29.612] (II) LoadModule: "sis"
[    29.613] (II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
[    29.632] (II) Module sis: vendor="X.Org Foundation"
[    29.632]    compiled for 1.19.1, module version = 0.10.9
[    29.632]    Module class: X.Org Video Driver
[    29.632]    ABI class: X.Org Video Driver, version 23.0
[    29.632] (II) SIS: driver for SiS chipsets: SIS5597/5598, SIS530/620,
   SIS6326/AGP/DVD, SIS300/305, SIS630/730, SIS540, SIS315, SIS315H,
   SIS315PRO/E, SIS550, SIS650/M650/651/740, SIS330(Xabre),
   SIS660/[M]661[F|M]X/[M]670/[M]741[GX]/[M]760[GX]/[M]761[GX]/[M]770[GX],
   SIS340
[    29.632] (II) SIS: driver for XGI chipsets: Volari Z7 (XG20),
   Volari V3XT/V5/V8/Duo (XG40)
[    29.634] (WW) Falling back to old probe method for sis
[    29.634] (EE) No devices detected.
[    29.634] (EE)
Fatal server error:
[    29.634] (EE) no screens found(EE)
[    29.634] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    29.634] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    29.634] (EE)
[    29.635] (EE) Server terminated with error (1). Closing log file.


This thread replaces a formerly written thread on this subject with too many errors.
Does somebody have ideas about this problem. I am sure it should work as I succeeded to run SiS671 on an Ubuntu16.04 with a nice 1280x800 resolution and a nice picture.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby jcglt » 2017-04-03 08:58

I close this thread with too many errors and replace it by a new thread with the same subject.
Last edited by jcglt on 2017-04-04 02:48, edited 1 time in total.
jcglt
 
Posts: 19
Joined: 2017-03-26 03:13

Re: Debian 9 stretch with SiS 671/771

Postby dilberts_left_nut » 2017-04-03 09:50

Threads merged - keep it in one place please.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4703
Joined: 2009-10-05 07:54
Location: enzed

Next

Return to System configuration

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable