[SOLVED] Debian Stretch kernel shows 4.5 after upgrade

Kernels & Hardware, configuring network, installing services

[SOLVED] Debian Stretch kernel shows 4.5 after upgrade

Postby ticojohn » 2017-04-03 21:08

I just completed an install of Stretch amd64. I did this using rc-1 because I had it on hand from last May when I installed Stretch on my Intel NUC. The kernel installed was 4.5 so after the install was complete I did a dist-upgrade. The upgrade showed that it was upgrading the kernel to 4.9, and indeed 4.9 is installed. Verified by trying to install the latest image.
Code: Select all
root@debian:/home/john# apt-get install linux-image-amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-image-amd64 is already the newest version (4.9+79).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

However, uname -a shows that it appears to still be using kernel 4.5.
Code: Select all
root@debian:/home/john# uname -a
Linux debian 4.5.0-2-amd64 #1 SMP Debian 4.5.3-2 (2016-05-08) x86_64 GNU/Linux

Am I missing something? Probably but can someone give me a hint.

UPDATE: By the way, initrd.img is 4.9 and vmlinuz is also 4.9 . So why doesn't uname also give me 4.9 ?

SOLVED: Dummy me! I forgot to update grub after I updated the kernel. DOH !!!!!

UPDATE 2: Also had something strange happen, before I updated grub. When I tried to boot Debian 9 I got a message something like this:
Code: Select all
Attempt to read or write outside the boundary of hd0

After updating grub all is well.
I'm not irrational, I'm just quantum probabilistic.
User avatar
Posts: 772
Joined: 2009-08-29 18:10
Location: Costa Rica

Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests