Unable to boot due to NFS start job.

Kernels & Hardware, configuring network, installing services

Unable to boot due to NFS start job.

Postby thegiantcat1 » 2017-04-06 10:11

Hello,

I am having an issue with a system running Debian 8.7.1 i386, when I go to boot I get a startup job that runs:

a start job is running for lsb: nfs support files...

There is no limit on this start job, I checked the following but am lost at this point.
1. Made sure there was no NFS share getting mounted in FSTAB
2. Added "allow-hotplug" into my network config file, as well as commenting out the whole file, and also using a static.
3. Checked scripts in /etc/init.d/ none of these as far as I could see were causing the issue, I commented out all scripts that had mention of NFS
4. Re imaged the system with the original image to make sure it wasn't something I had done that caused this issue.

Basically at this point I just want to either set a timeout for the startup job, skip it, or disable NFS all together unfortunately I am unable to find where the job is running from. Is there a way to find this.

As a note the only way I am able to access this file system currently is from booting from a CD and going into rescue mode.
thegiantcat1
 
Posts: 2
Joined: 2017-04-06 09:41

Re: Unable to boot due to NFS start job.

Postby acewiza » 2017-04-06 16:44

You likely have a failing drive. Just a WAG. :(
User avatar
acewiza
 
Posts: 191
Joined: 2013-05-28 12:38
Location: Out West

Re: Unable to boot due to NFS start job.

Postby thegiantcat1 » 2017-04-06 18:26

I thought that might be the case as well. I threw the image on a separate drive and got the same issue. It wouldn't be a problem, however the start job has no timeout so it just sits on it forever.
thegiantcat1
 
Posts: 2
Joined: 2017-04-06 09:41

Re: Unable to boot due to NFS start job.

Postby bw123 » 2017-04-06 20:50

I've been messing with these trying to get kernel 4.9 to boot on this machine.

https://www.freedesktop.org/software/sy ... -line.html

In your case, maybe masking networking.service will get you in? I recall some issues with networkmanager not being up when networking tries to start also, try either mask NetworkManager.service it or tell systemd that network.service rquires it?

Wish I could tell you how to do that from the kernel command line, but there are links to the man pages online at the link.

These issues are one reason I always keep sysvinit available.
jessie/KDE4.14.2 plasma netbook, 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
User avatar
bw123
 
Posts: 2378
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Unable to boot due to NFS start job.

Postby pylkko » 2017-04-07 06:33

Code: Select all
sudo systemctl list-units

You might find either nfs-server.service or nfs-client.target or sometihng and just disable them.
User avatar
pylkko
 
Posts: 894
Joined: 2014-11-06 19:02


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable