rc.d is missing on debian 8.7.1

Kernels & Hardware, configuring network, installing services

rc.d is missing on debian 8.7.1

Postby Osiris » 2017-04-14 18:58

I installed Komodo, but at the moment when I run the program a problem appear, telling me that

(komodo:1563): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
I saw that this problem occurs because I dont have the folder /etc/rc.d
I only have /etc/rc0.d or rc1.d or rc2.d or rc3.d or rc4.d or rc5.d or rc6.d or rc.local or rcS.d
Somebody can help me to obtain the folder that is missing rc.d Im working on debian 8.1.7 jessie
Osiris
 
Posts: 1
Joined: 2017-04-14 18:49

Re: rc.d is missing on debian 8.7.1

Postby stevepusser » 2017-04-14 21:46

Obviously, if you cram an entire Indonesian island, even a smallish one like Komodo, into your computer, there's not going to be room left for anything else. :D Those dragons can wiggle around and corrupt data, too.

If you mean something else besides the island, maybe telling us exactly what non-Debian program you're talking about from the start, along with links and the exact steps you followed to install it, would inspire more people to help you.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.4, Pale Moon 27.3.0, Liquorix kernel 4.11-4, mpv 0.25.0, Kodi 17.1, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8221
Joined: 2009-10-06 05:53

Re: rc.d is missing on debian 8.7.1

Postby GarryRicketson » 2017-04-14 22:40

There is some results in a search about how to get or create a rc.d file,..
rc.d is missing on debian 8
First hit:
http://stackoverflow.com/questions/20959534/debian-update-rc-d-command-not-found
apt-get install sysv-rc worked for me. thanks! – zanona Sep 23 '14 at 22:31


This package is needed.
https://packages.debian.org/jessie/sysv-rc-conf

https://wiki.debian.org/LSBInitScripts/DependencyBasedBoot

Code: Select all
man update-rc.d
might be of some help, but it is not part of a default Debian 8 install, the above mentioned package needs to be installed
first.
I am just guessing, but I think the OP is talking about this:
Komodo is commercial software, a IDE/Editor and is not something I would even think about installing on my system, but as Steve says, we would need some details on what version, and where it was downloaded from, It is not for free, a license is required, and there are many sites offering downloads. There is a Demo
version, but who knows ? Maybe "startpage.com" or "google" knows more.
======edited============
This is really funny to me,...I decided to ask "google", about a install manual
for this software:
But it kind of explains why it is looking for a "rc.d" file,...somewhat outdated
since Debian 8 does not have a rc.d file or directory.
It says this is the "latest" version
Home
Manual
install | Komodo IDE/Edit Documentation
( Komodo Version: Latest

From: http://docs.komodoide.com/Manual/installOther operating systems:


Komodo may also run on other Linux based systems, or older versions of the above OS. You will need to verify this yourself, as Komodo is not tested on other platforms; and platform-specific bugs may exist there.

Debian GNU/Linux 4.0 ("etch")
Mandriva
FreeBSD (with Linux binary compatibility)
Gentoo


Just guessing,again, but if it is the Komodo editer , there is a open source "free" version available , they have it on github, How ever if that is what the OP is refering to, honestly, I think they would be better off using "Vim", which is in the Debian repositories,. uptodate and supported.
https://packages.debian.org/jessie/vim-gtk
VIM should install with out any problems like this, and is more extensible.
See: https://fusion809.github.io/free-text-editors-and-ides/#toc18
User avatar
GarryRicketson
 
Posts: 3863
Joined: 2015-01-20 22:16
Location: Durango, Mexico


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable