[solved] exim4 can't update

Kernels & Hardware, configuring network, installing services

[solved] exim4 can't update

Postby HankB » 2017-04-27 19:12

Hi all,
I've got a Debian 9 desktop that is experiencing difficulty updating exim4. The result of trying to upgrade is:
Code: Select all
root@olive:/home/hbarta# apt -y upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up exim4-config (4.89-2) ...
2017-04-27 14:54:34 Exim configuration error in line 685 of /var/lib/exim4/config.autogenerated.tmp:
  group mail was not found
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing
/var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.autogenerated
dpkg: error processing package exim4-config (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of exim4-base:
 exim4-base depends on exim4-config (>= 4.82) | exim4-config-2; however:
  Package exim4-config is not configured yet.
  Package exim4-config-2 is not installed.
  Package exim4-config which provides exim4-config-2 is not configured yet.

dpkg: error processing package exim4-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.89); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4-daemon-light
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@olive:/home/hbarta#

The error report seems to be:
Code: Select all
2017-04-27 14:54:34 Exim configuration error in line 685 of /var/lib/exim4/config.autogenerated.tmp:
  group mail was not found


And the mail group seems to exist:
Code: Select all
root@olive:/home/hbarta# grep mail /etc/group
mail:x:8:
root@olive:/home/hbarta#

I don't ordinarily use local email on this host but the exim package seems to be pulled in by another package (smartmontools?)

I'm at a loss as to how to fix this. I'm not against installing a different mta but sendmail.cf still scares me. ;)

Thanks!
Last edited by HankB on 2017-05-01 11:49, edited 1 time in total.
HankB
 
Posts: 17
Joined: 2012-03-07 15:15

Re: exim4 can't update

Postby levlaz » 2017-04-28 00:25

Iv'e never seen this before, but I dug up this issue [1] on CentOS from a few years ago. Could you check the permissions to make sure they look ok?

[1] https://forums.cpanel.net/threads/exim- ... und.32781/
Best,

Lev
Blog
User avatar
levlaz
 
Posts: 179
Joined: 2012-09-27 12:06
Location: San Francisco, CA

Re: exim4 can't update

Postby HankB » 2017-05-01 11:48

Many thanks for your help. File permissions seem to be the issue. /etc/group somehow got changed to 600. I changed it to 644 and then the exim update completed, albeit with this seemingly harmless warning:
Code: Select all
W: APT had planned for dpkg to do more than it reported back (140 vs 144).
   Affected packages: exim4-config:amd64


best,
hank
HankB
 
Posts: 17
Joined: 2012-03-07 15:15

Re: [solved] exim4 can't update

Postby levlaz » 2017-05-02 05:11

Glad you were able to get this to work!
Best,

Lev
Blog
User avatar
levlaz
 
Posts: 179
Joined: 2012-09-27 12:06
Location: San Francisco, CA


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable