can't change ssh config file

Kernels & Hardware, configuring network, installing services

can't change ssh config file

Postby DebianNoob83 » 2017-05-07 14:32

hi there. i'm trying to change some of the values in my ssh config file in order to harden its security,based on ssh hardening tutorials i've found online. but i can't seem to open ssh config through terminal even as root, still says permission denied.
also i can't change the file directly because its set to read only, what am i doing wrong here?
Posts: 1
Joined: 2017-05-07 14:16

Re: can't change ssh config file

Postby pkladisios » 2017-05-07 15:25

If you are accurate in your description, then yes it is peculiar. You should provide us with some basic information:
-File permissions. That can be achieved by typing into the terminal
Code: Select all
ls -la

-Terminal output. What error is returned when you try to alter the contents of the file?
-What program do you use to edit the file? Most people use vi, vim or nano.

Even though it is generally not considered to be a good practice, have you tried staying logged on as the root in the terminal?
Lastly, have you tried shutting down the ssh service? I think that some services lock their configuration files when active.
Posts: 26
Joined: 2016-10-18 13:04

Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests