No DHCPOFFERS received

Kernels & Hardware, configuring network, installing services

No DHCPOFFERS received

Postby aobs » 2017-06-26 08:43

Modem: Huawei ME906s-158
Computer: Raspberry Pi

I am getting this error message

    No DHCPOFFERS received

Am I missing a step?

Running usb-devices shows:

Code: Select all
T:  Bus=01 Lev=02 Prnt=02 Port=04 Cnt=04 Dev#=  6 Spd=480 MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=ff MxPS=64 #Cfgs=  3
P:  Vendor=12d1 ProdID=15c1 Rev=01.02
S:  Manufacturer=HUAWEI Mobile
S:  Product=HUAWEI Mobile
S:  SerialNumber=0123456789ABCDEF
C:  #Ifs= 3 Cfg#= 3 Atr=a0 MxPwr=2mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=0e Prot=00 Driver=cdc_mbim
I:  If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=02 Driver=cdc_mbim
I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=06 Prot=14 Driver=option


Running ip addr shows:

Code: Select all
5: wwan0: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1460 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 4a:f3:aa:36:b1:34 brd ff:ff:ff:ff:ff:ff


Use minicom -D /dev/ttyUSB0 to enter

Code: Select all
AT+CGDCONT=1,"IP","apn"
AT+CGACT=1,1


and also tried

Code: Select all
AT^NDISDUP=1,1,"apn"
OK
AT^NDISSTATQRY?
^NDISSTATQRY: 1,,,"IPV4"



Run dhclient -v wwan0 shows

Code: Select all
Listening on LPF/wwan0/4a:f3:aa:36:b1:34
Sending on   LPF/wwan0/4a:f3:aa:36:b1:34
Sending on   Socket/fallback
DHCPREQUEST on wwan0 to 255.255.255.255 port 67
DHCPREQUEST on wwan0 to 255.255.255.255 port 67
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
Trying recorded lease 100.xxx.xx.x
PING 100.xxx.xx.x (100.xxx.xx.x) 56(84) bytes of data.

--- 100.xxx.xx.x ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

bound: renewal in 230490 seconds.
aobs
 
Posts: 1
Joined: 2017-06-26 08:12

Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable