[Stretch - SAMBA] Cannot access from Windows XP

Kernels & Hardware, configuring network, installing services

[Stretch - SAMBA] Cannot access from Windows XP

Postby marmz » 2017-06-30 12:47

I just upgraded to Debian 9 (Stretch).
Now i wanted to restore my Samba share(s), so:

  • Installed samba packages

  • Adjusted config file
    Code: Select all
    /etc/samba/smb.conf

  • Created smb user (marmz):
    Code: Select all
    smbpasswd -a marmz


But i cannot access Linux shared folders from my Win XP machine anymore!!
When i click on some shared folder, "login" window appears;
so i enter User & Passwd, but there's no way to authenticate, since the login window continue appearing without throwing any errors!!!

Instead, my other "non-microsoft" devices have NO problems with the SMB share ... :?

Maybe i am missing some option to help old Windows accessing Samba folders (but remember that on my previous system(s) it always worked perfectly) ...

I'm lookin for some good idea guys!

I wanted to attach here my "smb.conf" file .. but the forum is filtering file extensions, so i had to upload it on a domain.
It is the same config i was using on Jessie, before upgrading;

http://www.codipe.it/mzweb/smb.conf

Thanks in advance for any help! :wink:
marmz
 
Posts: 3
Joined: 2017-06-30 11:38

Re: [Stretch - SAMBA] Cannot access from Windows XP

Postby marmz » 2017-07-17 16:58

UP!

i can't believe that nobody is answering.. :(
please guys, it's so frustrating that such a stupid problem can't be resolved! :roll:
marmz
 
Posts: 3
Joined: 2017-06-30 11:38

Re: [Stretch - SAMBA] Cannot access from Windows XP

Postby Leuleu » 2017-07-17 21:27

Hi,

I had the same issue since upgrade to Stretch : cannot authenticate from an XP workstation.

I checked changes in the new Samba server release and found the following :
https://wiki.samba.org/index.php/Samba_ ... by_default
By default, Samba will only allow NTLMv2 via NTLMSSP now, as we have the following default "lanman auth = no", "ntlm auth = no" and "raw NTLMv2 auth = no".


In my smb.conf, I added the following line and it works now :
Code: Select all
ntlm auth = yes


It is probably a bad thing regarding security, but it seems there is no other choice...

Hope this helps,
Leuleu
 
Posts: 1
Joined: 2017-07-17 21:16

Re: [Stretch - SAMBA] Cannot access from Windows XP

Postby marmz » 2017-07-18 19:21

hmmm .. in my "smb.conf" there's no default setting for "ntlm auth" :?

Anyway, setting "ntml auth = yes" made the trick.. as you said! :P Thank you much man!
marmz
 
Posts: 3
Joined: 2017-06-30 11:38


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable