pulseaudio: only one application at a time (SOLVED)

Kernels & Hardware, configuring network, installing services

pulseaudio: only one application at a time (SOLVED)

Postby morgon » 2017-07-09 02:12

Hi,

seems I made the biggest mistake for a long time in attempting a fresh install of stretch. Nothing but problems for me....

So now this: It seems that pulseaudio (I have not yet changed any config manually) only allows one application at a time to output sound.

So e.g as long as I play sound via mpd a youtube video will not run.

anyone with an idea?

Many thanks!
Last edited by morgon on 2017-07-12 20:15, edited 1 time in total.
morgon
 
Posts: 70
Joined: 2010-08-28 03:04

Re: pulseaudio: only one application at a time

Postby orythem27 » 2017-07-09 05:03

morgon wrote:So e.g as long as I play sound via mpd a youtube video will not run!

Are you sure that mpd actually uses pulseaudio? (So that it does not directly grab the alsa device?)

Open pavucontrol while mpd is playing, can you see mpd in the "Playback" tab?

If not sure, can you name another example? (without mpd involved)

See:
https://askubuntu.com/questions/555103/mpd-with-pulseaudio
https://unix.stackexchange.com/questions/287678/pulseaudio-and-mpd
User avatar
orythem27
 
Posts: 245
Joined: 2017-05-11 07:59
Location: P.R. China

Re: pulseaudio: only one application at a time

Postby morgon » 2017-07-12 19:50

Hi, many thanks for your reply, you may be on to somthing....

When I play sound via mpd in fact I don't see mpd in pavucontrol... but eg. chromium shows up.

But my mpd is configured like this:

Code: Select all
audio_output {
        type            "pulse"
        name            "MPD Output"
}


Which I assumed would ensure that mpd uses pulseaudio.

I don't understand this anymore....

UPDATE:

It is not a pulseaudio problem. I can e.g. simultaniously play sound via firefox and chromium. But a running mpd, configured as above seems to block the audio.
morgon
 
Posts: 70
Joined: 2010-08-28 03:04

Re: pulseaudio: only one application at a time (SOLVED)

Postby morgon » 2017-07-12 20:12

Ok. This is what seems to work:

Initially I had a problem with mpd not being able to connect to pulseaudo, which is why I commented out the "server". Then mpd plays but seems to block other apps from playing sound.

To make it work configure mpd like this:

Code: Select all
audio_output {
            type            "pulse"
            name          "MPD Output
            server         "localhost"
}


And then run paprefs and check "Enable network access to local sound devices".

I don't claim to fully understand what I am doing here, but it seems to work.
morgon
 
Posts: 70
Joined: 2010-08-28 03:04


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable