[SOLVED] dpkg nvidia-installer-cleanup issue

Kernels & Hardware, configuring network, installing services

[SOLVED] dpkg nvidia-installer-cleanup issue

Postby jalisco » 2017-07-16 19:47

Hello,

I am using Jessie, and was just updating some software.

I guess I have learned my lesson now, and that is, just don't blindly update software unless you know what it is =(

I restarted my system, and get the "oh no, something is terribly wrong" message.

I can only login to recovery mode, as root. If I try to run startx, it also fails. After some log digging, I think it has to do with my video card.

When I try to update my driver, the system seems to hang on the "nvidia-installer-cleanup" forever.

Now, after a couple of restarts, the problem has not resolved itself.

I get the message that I need to run "dpkg --configure -a" to fix it (to complete the above application, but regardless of options, the system just hangs). Granted, I have only waited about an hour -- should I wait longer?

Can anyone give me any other pointers, or ideas? It shouldn't be that complicated, should it? I already started migrating my data, and planning to just re-install unless I can get a helpful tip, in the right direction.

Thanks!
Last edited by jalisco on 2017-07-17 09:52, edited 1 time in total.
jalisco
 
Posts: 39
Joined: 2013-09-01 17:30

Re: dpkg nvidia-installer-cleanup issue

Postby pylkko » 2017-07-17 05:45

That package says in the description that it prevents driver upgrades. So maybe you updated the drive from a third party source and had this package installed? Maybe try remove it
User avatar
pylkko
 
Posts: 960
Joined: 2014-11-06 19:02

[SOLVED]dpkg nvidia-installer-cleanup issue

Postby jalisco » 2017-07-17 09:51

I just wanted to return to confirm your recommendation.

I actually figured it out last night. The issue was precisely the AGP driver.

As mentioned, I got myself stuck in some funny state, because I was unable to run the uninstaller -- it would just hang.

Eventually I just deleted it, and installed the new driver.

More precisely, in case anyone runs into a similar problem.

I only had access to the command line (root) from recovery mode. Fortunately, I had setup an ftp server recently on another machine, and was able to download the new driver there, and just ftp from the command line, and "get" the driver.

Then, I had to delete the nvidia-installer-cleanup on my system, and then run the new installer.
jalisco
 
Posts: 39
Joined: 2013-09-01 17:30


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable