working with xrandr 1.5 not finding how to connect second or

Kernels & Hardware, configuring network, installing services

working with xrandr 1.5 not finding how to connect second or

Postby dabeegmon1 » 2017-07-19 00:02

Greetings

Running debian buster (testing) using lxqt. Have 3 nvidia 570 gpus and 4 1920x1080 monitors.
Have had this system running since early 2012.

Did a system upgrade to buster from stretch.

Found that there were some issues with proprietary drivers nvidia 375.66 - - - was having one gpu halt and upon reboot things seemed to work again. The time between reboots was getting down to less than 12 hrs when I landed up with a system with corrupted networking on a reboot.
So in the process of re-install I decided to try the Nouveau drivers instead. So now I have a one gpu 2 monitor system available. Got to very much like the four monitors for my work layout so I want the other two monitors working.

Using xrandr I can see Provider 0,1 and 2.
DVI-I-1 and DVI-I-2 are connected.
DVI-I-2-5 and DVI-I-2-6 are listed as disconnected.

I have been able to create a virtual screen of 3840 x 3000 which is how I had things before this reinstall
using $xrandr --fb 3840x3000 .
Tried $xrandr --setprovideroutputsource 1 0
no changes
looked for pci addresses
found 01:00.0. 02:00.0 and 03:00.0

Looked in the kernel log and all I can see is a error code of -19 (for both Provider 1 and 2) which, after a lot of digging, seems to be saying "no such device"
Tried $ xrandr --addmode DVI-I-2-5 1920x1080
then DVI-I-2-5 still shows as disconnected but with a resolution of 1920x1080 60.00
Next I tried $ xrandr --output VGA-2 --mode 1920x1080 --pos 1280x1280 --rotate inverted
result - - warning: output VGA-2 not found; ignoring

It used to be that this setup happened in xorg.conf (and was a monolithic file), then things were changed to files placed in /etc/xorg.conf.d (as individual descriptions - - - ie. devices, monitors and AIUI screens) and in my system these kind of files are now in /etc/X11/Xsession.d but there aren't any to do with graphics issues.

Any information I haven't provided that would help others help me?

I can't find any guides on how to setup xrandr to use multiple gpus AND more than 2 or 3 monitors (usually from only 1 gpu).
Most of the randr information I can find is for at newest randr 1.3 and I have 1.5. Randr 1.4 is where the multiple gpu option was introduced so it should be possible but . . . .

I've found
https://cgit.freedesktop.org/xorg/pr...oto-1.5.0#n160
likely everything I need is hidden in this file but for the life of me I can't figure out what commands to use. If I were an expert I wouldn't be asking but I'm not and there are no examples to follow (or try).

Suggestions please?

(Maybe do I have to go for newer proprietary drivers? (rather not I sort of like the no issues right now with Nouveau!)

TIA
dabeegmon1
 
Posts: 1
Joined: 2017-07-18 23:56

Return to System configuration

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable