Boot fail randomly without "acpi=off"

Kernels & Hardware, configuring network, installing services

Boot fail randomly without "acpi=off"

Postby aNewDebianUser » 2017-07-22 08:31

Hello,

I am using Debian Stretch and the boot fail randomly when i do not add the boot option "acpi=off".
It freeze and i have to hard reboot.

However adding "acpi=off" doesn't allow me to use an external display (via HDMI).

I also tried several option like "acpi_osi" and else but none with great sucess.

Would you have a lead about what is going on and how to fix the boot of Debian ?

Thanks
aNewDebianUser
 
Posts: 5
Joined: 2017-07-22 08:10

Re: Boot fail randomly without "acpi=off"

Postby kedaha » 2017-07-22 09:48

Hi,
I was interested to read your post as I've sometimes had such issues in the past.
I see you've tried alternative boot options so you've done some searches and have no doubt found that acpi=off is not ideal.
I definitely think you should report this as a bug.
Using the liquorice kernel might be an option until the issue is resolved via reporting the bug.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable & Software

Words, as is well known, are the great foes of reality. Joseph Conrad.
User avatar
kedaha
 
Posts: 2794
Joined: 2008-05-24 12:26

Re: Boot fail randomly without "acpi=off"

Postby aNewDebianUser » 2017-07-26 21:14

Hi,
I am not sure to know how to report a bug to Debian, As I don't know the package involved, I am now following the processus : mail sent in order to know the "How to".
About Liquorice, i am not sure to understand what it is and how it could help : It seems made to improve performances, but doesn't speak much about fixing bugs. Wouldn't SID be better on that regard ? Isn't supposed to be the most up to date kernel ?
During some more research, I fall on some stuff about DSDT. It seems a good lead : related to ACPI and used to be easily replace even if it is not the case anymore. However I didn't find yet time to find good article about it.
As I am starting with Debian, I don't know if I am missing some steps and would welcome any advise.
Oh and 2 more facts : without the "acpi=off" option using the "lspci" command make crash debian.
And it is also the case when i launch "System information".
I will dig out to give more information about how that happened
Thanks,
aNewDebianUser
 
Posts: 5
Joined: 2017-07-22 08:10

Re: Boot fail randomly without "acpi=off"

Postby aNewDebianUser » 2017-07-26 22:08

lspci command result :
lspci : debian crash (like during the boot, not always, but often)
lspci -s 00: OK
lspci -s 01: debian crash (like during the boot, not always but often)
lspci -s 02: Ok
lspci -s 03: OK

With the boot option "acpi=off"
lspci : OK
lspci -s 01: OK

And the culprit is :
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
Subsystem: Micro-Star International Co., Ltd. [MSI] GM107M [GeForce GTX 960M]
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at d0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at df000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Legacy Endpoint, MSI 00
Kernel modules: nvidia
Last edited by aNewDebianUser on 2017-07-26 22:45, edited 1 time in total.
aNewDebianUser
 
Posts: 5
Joined: 2017-07-22 08:10

Re: Boot fail randomly without "acpi=off"

Postby dasein » 2017-07-26 22:10

aNewDebianUser wrote:Wouldn't SID be better on that regard ?

No

Sid in the unstable development branch of Debian, not at all suitable for novices.

You might want to consider switching to a more "newbie-friendly" distro. Most Debian users started that way.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Boot fail randomly without "acpi=off"

Postby aNewDebianUser » 2017-07-26 22:40

dasein wrote:You might want to consider switching to a more "newbie-friendly" distro.

I used to consider that. Around February, I tried like 7 of them in severals versions with no success, sometimes to use the liveCD, sometimes to boot them after the installation.
At that time, Jessie was the Debian stable one. But Jessie didn't boot while Stretch did.
I still don't know what Stretch have which doesn't cause a stall on CPU when I boot it and that the others distributions lacks, tho.
aNewDebianUser
 
Posts: 5
Joined: 2017-07-22 08:10

Re: Boot fail randomly without "acpi=off"

Postby aNewDebianUser » 2017-07-31 21:46

kedaha wrote:Using the liquorice kernel might be an option until the issue is resolved

I did try it today : it gives me the same behavior that with the boot option "acpi=off" :
- External screen doesn't work anymore via HDMI
- It triggers a message in cinnamon which says that it runs in software rendering mode (support mode, not normal mode)
(with nomodeset boot option and nouveau driver blacklisted. Without any boot option, it did freeze on a black screen)
aNewDebianUser
 
Posts: 5
Joined: 2017-07-22 08:10


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable