yet another airplane mode problem [solved]

Kernels & Hardware, configuring network, installing services

yet another airplane mode problem [solved]

Postby agrimstad » 2017-07-31 11:47

I think airplane mode in gnome3 is causing me problems and I'm looking for a way to get rid of it. Since my computer is a desktop, airplane mode is totally useless to me anyway. All my web searches are turning up help on how to fix airplane mode on laptops, which is no help at all to me.

First, my wifi hardware and associated linux kernel stuff is working fine. When I boot into rescue mode, wifi always is working.

The problem starts when I either boot into the gnome3 gui or exit rescue mode and continue on to the gnome3 gui. At that point two things, which I assume are correlated, are present: airplane mode is on and my wifi is not working.

To get wifi working I have to turn off airplane mode and then do some number of ifdown/ifup wlan0 before wifi starts working. I also seem to have to delete /run/wpa* stuff too.

I'm running jessie with the latest updates. (I'm not supplying hardware info since it's working.)

# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 8.9 (jessie)
Release: 8.9
Codename: jessie


I've uninstalled the network-manager package and configure my pci wireless adapter via /etc/network/interfaces.d/*. As I said, this all works. What I'm trying to do is to get gnome3 from messing it up. Thanks for any tips.

By the way, this problem isn't present in stretch and wasn't present in jessie initially. It was introduced, I think, in some update to jessie.
Last edited by agrimstad on 2017-08-01 13:20, edited 1 time in total.
agrimstad
 
Posts: 84
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: yet another airplane mode problem

Postby deborah-and-ian » 2017-07-31 15:50

agrimstad wrote:By the way, this problem isn't present in stretch and wasn't present in jessie initially. It was introduced, I think, in some update to jessie.

So, let me get this straight: You had Jessie installed, it worked and now it makes those problems. I don't think that Debian devs would change such behaviour for an oldstable release. That's just not possible. Either the bug has always been there and just never fixed, or it isn't a bug but a configuration issue (which I'd say is the more likely culprit).

However, I didn't know Gnome3 worked without Network Manager at all. Maybe that's your problem? Not sure if Gnome3 was meant to work with the classic network settings in /etc. It could be that some change in security policy by Debian causes these problems and the old code of Gnome can't deal with it? Just guessing though.
Debian GNU/Linux 9 Stretch

Acer Aspire E5-521G
AMD A8-6410 APU
8 GB RAM
integrated AMD Mullins
dedicated AMD Hainan Radeon R5 M240 2 GB
240 GB Toshiba Q300 SSD
Realtek RTL8111/8168/8411 ethernet
Qualcomm Atheros QCA9565 wireless
deborah-and-ian
 
Posts: 137
Joined: 2016-07-13 08:40

Re: yet another airplane mode problem

Postby Bulkley » 2017-07-31 16:16

[url]I've uninstalled the network-manager package and configure my pci wireless adapter via /etc/network/interfaces.d/*[/url]

Make sure that network-manager didn't leave some configs behind.

Try moving the wpa-supplicant instructions from /etc/network/interfaces.d/* to /etc/network/interfaces . It probably won't change anything but the experiment is easy and may work. Just out of curiosity, what are your wpa-supplicant instructions?
Bulkley
 
Posts: 5240
Joined: 2006-02-11 18:35

Re: yet another airplane mode problem

Postby agrimstad » 2017-07-31 16:36

[url]I've uninstalled the network-manager package and configure my pci wireless adapter via /etc/network/interfaces.d/*[/url]

Make sure that network-manager didn't leave some configs behind.


I uninstalled it via apt-get. I don't know how to start looking for something that apt-get forgot to remove. I've never used network manager, so don't know much about it. It's one of the first things I used to remove when installing debian. On my test computer, which is running stretch, I left network manager installed, but configured the net via /etc/network and things seem fine. It's just not that convenient for me at the moment to install stretch on my personal workstation.

Try moving the wpa-supplicant instructions from /etc/network/interfaces.d/* to /etc/network/interfaces . It probably won't change anything but the experiment is easy and may work. Just out of curiosity, what are your wpa-supplicant instructions?


Note that /etc/network/interfaces has this as its first statement:

Code: Select all
source /etc/network/interfaces.d/*


So I don't think your suggestion is going to help me any. Thanks, though.

My config file in /etc/network/interfaces.d/ is totally vanilla:

Code: Select all
auto wlan0
iface wlan0 inet static
address 172.20.104.x
netmask 255.255.255.0
network 172.20.104.0
gateway 172.20.104.y
dns-nameservers 172.20.104.z
wpa-ssid My-SSID
wpa-psk zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz


If I don't hear any really great ideas on this forum, I might reinstall networkmanager and see if I can work around it the way I've done with stretch.
agrimstad
 
Posts: 84
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: yet another airplane mode problem [solved]

Postby agrimstad » 2017-08-01 13:38

OK, so I tried various things and have sorted out this problem.

First, the airplane mode icon seems to be signaling that the network interface is blocked. Interacting with the icon to turn off airplane mode, though, is the wrong way to tackle the problem. At least for me with Debian Jessie.

In dealing with airplane mode, I was dealing with a symptom of the problem, not the problem itself. So I found this link:

https://unix.stackexchange.com/questions/350148/permanently-disable-airplane-mode-gnome-3-2

It did make airplane mode disappear, but it didn't fix my problems with getting wifi running again on my desktop. So I undid the change made via gsettings.

If fact, this morning the problem was worse as I couldn't even get wifi working in single user mode, so gnome3 has to absolved from guilt here. Luckily, I got a new error diagnostic, which I hadn't seen before, which led me, I hope, to a solution to the problem: "operation not possible due to RF-kill."

Googling this error message got me to:

http://www.geekmind.net/2011/01/linux-wifi-operation-not-possible-due.html

The command
Code: Select all
rfkill list all
executed as root showed that the wifi interface was blocked. So, the command
Code: Select all
rfkill unblock all
can be used to unblock. When I did this, the airplane mode icon disappeared. Yeah! And
Code: Select all
ifup wlan0
quietly worked, bringing up my wifi interface.
agrimstad
 
Posts: 84
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: yet another airplane mode problem [solved]

Postby deborah-and-ian » 2017-08-01 17:36

Is that a wireless driver regression then? And how could it occur with static kernel and wireless drivers (assuming it wasn't there before on Jessie)?
Debian GNU/Linux 9 Stretch

Acer Aspire E5-521G
AMD A8-6410 APU
8 GB RAM
integrated AMD Mullins
dedicated AMD Hainan Radeon R5 M240 2 GB
240 GB Toshiba Q300 SSD
Realtek RTL8111/8168/8411 ethernet
Qualcomm Atheros QCA9565 wireless
deborah-and-ian
 
Posts: 137
Joined: 2016-07-13 08:40

Re: yet another airplane mode problem [solved]

Postby agrimstad » 2017-08-01 17:51

I can't answer your questions. All I know is that at some point something started blocking wlan0 in Jessie on my specific hardware. Fortunately, the basic problem is clear, if not the source of it, and there is a relatively simple fix. I don't have the ability (or time or interest) to figure out exactly what happened when.
agrimstad
 
Posts: 84
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: yet another airplane mode problem [solved]

Postby deborah-and-ian » 2017-08-01 20:06

It's solvable, that's what counts. :)
Debian GNU/Linux 9 Stretch

Acer Aspire E5-521G
AMD A8-6410 APU
8 GB RAM
integrated AMD Mullins
dedicated AMD Hainan Radeon R5 M240 2 GB
240 GB Toshiba Q300 SSD
Realtek RTL8111/8168/8411 ethernet
Qualcomm Atheros QCA9565 wireless
deborah-and-ian
 
Posts: 137
Joined: 2016-07-13 08:40


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable