Notebook fails to resume from suspend-to-disk in Stretch

Kernels & Hardware, configuring network, installing services

Notebook fails to resume from suspend-to-disk in Stretch

Postby PCXT » 2017-08-06 12:58

- Asus Eee PC 900
- Intel Celeron 900MHz
- 1GB of RAM
- 4GB of on-board SSD. Partitioned as 256MB /boot and rest is swap. Swappiness is 1.
- 16GB of secondary SSD, contains /.
- Intel 910 chipset.
- Stretch + LXDE installed from scratch.

With Jessie, suspending to disk was working perfectly. Now I installed Stretch after erasing both drives. Machine is Asus Eee PC 900, with swap on 4GB SSD, swappiness set at minimum to use this swap for hibernation, no encryption set at all.
So the system suspends properly, HDD light is on for some time, it writes image and turns off. During next boot-up it reads image, typical way and uswsusp shows reading too. Then the screen goes blank with blinking cursor. Screen is black, cursor is blinking, machine does not respond to any interactions except forcibly powering off by holding power button.

What I tried:
- Freezer, Devices, Platform, Processors and Core from pm_test - they all pass
- init=/bin/bash in kernel string and swapon / s2disk from there - black screen with cursor again.
- The same thing with added nomodeset - the same effect.
- Testing "shutdown" and "reboot" modes in /sys/power/disk
- shutdown causes machine to reboot at resume or black screen with cursor (chances are about 1/2, seems to be random)
- reboot causes black screen/cursor issue
- s2disk on swap file on the other SSD according to this - the same thing, black screen with cursor.

The resume attempt seems to be not present in kernel logs.

However, when using the following parameters to kernel:
Code: Select all
no_console_suspend ignore_loglevel init=/bin/bash

and going with s2disk, I could get a console hanging. It quickly scrolls through console, then clears the screen and hangs with:

Code: Select all
ACPI : EC: Event blocked
PM: quiesce of devices complete after 17.552 msecs
PM: late quiesce of devices complete after 0.779 msecs
ACPI : EC: interrupt blocked
PM: noirq quiesce of devices complete after 1.241 msecs
ACPI: EC: EC stopped
Disabling non-boot CPUs ...

I rmmod'ed all USB-related modules, ablk_helper, cryptd, libahci, atl2, psmouse, to get something minimum and s2disk with it... then it resumed successfully... ONCE.
Retried it exactly the same way (with no_console_suspend ignore_loglevel init=/bin/bash, same modules removed) - it failed.
Tried a couple of times, the same modules removed, it failed all times.

How to fix this problem?
Posts: 4
Joined: 2017-02-10 16:45

Return to System configuration

Who is online

Users browsing this forum: NFT5 and 5 guests