Getting Stretch to stay awake longer

Kernels & Hardware, configuring network, installing services

Getting Stretch to stay awake longer

Postby kendew » 2017-09-22 19:27

Running Debian Stretch with OpenBox WM with LightDM. The screen is blanking too fast for me. I'm targeting three areas to change this: xset, DPMS, and light-locker, the screen locker that gets installed with LightDM. I do not use, nor do I want to, Xscreensaver or other screen savers. My goal is not to disable blanking entirely but to extend it to an hour.

For xset I've written
Code: Select all
xset s 3600 3600 &
in OpenBox's autostart file.
For DPMS I've written a file /etc/X11/xorg.conf.d/10-monitor.conf:
Code: Select all
Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "60"
    Option "SuspendTime" "60"
    Option "OffTime"     "60"
    Option "BlankTime"   "60"
EndSection


My question so far is, so far do I have this right? Could it be better?
The next thing to deal with is light-locker because it seems to have the power to override above settings. I'm not sure how to deal with this. One possibility is to try uninstalling it. But in my OpenBox menu I am using dmtool to lock the screen and wonder if that would be affected. Also I'd prefer to edit rather than eliminate. I know there is a script https://github.com/Antergos/light-locker-settings/blob/master/light-locker-settings/light-locker-settings.py which sets to DPMS values for Antergos. I wonder what can be done here for Debian.
There is a program called caffeine that I've used to good effect on Arch systems, but the Debian version in the repositories doesn't seem to work well at the moment. Maybe when it gets upgraded?
Code: Select all
caffeine

** (caffeine:15178): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/usr/bin/caffeine:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gtk, GLib

Anyway, rather than caffeine, I'd prefer to just set screen locking or blanking myself.
Any suggestions appreciated.
Kendew
kendew
 
Posts: 30
Joined: 2014-10-12 19:59

Re: Getting Stretch to stay awake longer

Postby rmlrml » 2017-11-25 02:14

Came here looking for alternatives to caffeine, as the debian package has been untouched for 2 years and is marked for autoremoval on 30 November: https://tracker.debian.org/pkg/caffeine

"alternativeTo" page has no alternatives: https://alternativeto.net/software/caff ... opensource

Or any suggestions on OP's question would also help me.

OP kendew, did you figure anything out on this?
rmlrml
 
Posts: 2
Joined: 2017-11-25 02:02

Re: Getting Stretch to stay awake longer

Postby debiman » 2017-11-25 10:52

kendew wrote:For xset I've written
Code: Select all
xset s 3600 3600 &
in OpenBox's autostart file.
For DPMS I've written a file /etc/X11/xorg.conf.d/10-monitor.conf:
Code: Select all
Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "60"
    Option "SuspendTime" "60"
    Option "OffTime"     "60"
    Option "BlankTime"   "60"
EndSection


either of those should be sufficient in regard to op's question.

caffeine is a utility to stop the screen from blanking when flash or html5 video is playing.
or some other media player that isn't linux screensaver aware. a few years ago that was still an issue (VLC iirc) but not anymore.

my approach:
1. flash sucks. kill it with fire.
2. watch online videos with mpv with youtube-dl plugin - solves all screen blanking issues.

in case caffeine really still works on archlinux (ihave no intention of testing this), you could take a look at the PKGBUILD, maybe you can figure out how the build might succeed on debian.
User avatar
debiman
 
Posts: 1619
Joined: 2013-03-12 07:18

Re: Getting Stretch to stay awake longer

Postby Head_on_a_Stick » 2017-11-25 10:55

kendew wrote:The next thing to deal with is light-locker because it seems to have the power to override above settings. I'm not sure how to deal with this.

BunsenLabs uses light-locker and we have a nice HowTo that includes details about how to disable it:

https://forums.bunsenlabs.org/viewtopic.php?id=2080
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6784
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Getting Stretch to stay awake longer

Postby Bulkley » 2017-11-26 01:14

Here's a crazy idea to keep a machine awake. The neat thing is that it works.

Code: Select all
apt-get install frozen-bubble


Yeah, it's a game. Install it. When you open it the first time it plays some obnoxious noise so go into ~/.frozen-bubble/rc and change
Code: Select all
$mixer_enabled = 1; 

to
Code: Select all
$mixer_enabled = 0;


Whenever you play the game it will keep the machine awake so start the game, play a few balls, set it aside and do what you have to do.
Bulkley
 
Posts: 5363
Joined: 2006-02-11 18:35

Re: Getting Stretch to stay awake longer

Postby rmlrml » 2017-11-29 22:22

debiman wrote:caffeine is a utility to stop the screen from blanking when flash or html5 video is playing.
...
2. watch online videos with mpv with youtube-dl plugin - solves all screen blanking issues.


Yeah I use mpv for that a lot. Using the Open With add-on in Firefox, I can just right-click a video and Open With > mpv. mpv works really well for streaming videos, but I still don't always do that. Sometimes I just move through the website's interface to watch videos, and that's when I like having caffeine-indicator in my system tray.

Has anyone used MozPlugger or something like it to put mpv inside FF?

For those interested in caffeine, I submitted bugs.debian.org/881742 and it was very quickly addressed, and caffeine is now the latest version in Debian unstable, and is working for me once again!
rmlrml
 
Posts: 2
Joined: 2017-11-25 02:02

Re: Getting Stretch to stay awake longer

Postby None1975 » 2017-11-30 14:01

Bulkley wrote:Whenever you play the game it will keep the machine awake so start the game, play a few balls, set it aside and do what you have to do.

It is most craziest idea i have ever heard
:shock: :shock: :shock:
OS: Debian 9.2 / WM: Ratpoison
Debian Wiki | DontBreakDebian, Ratpoison
User avatar
None1975
 
Posts: 217
Joined: 2015-11-29 18:23
Location: Lithuania


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable