Problem with Wake-on-Lan settings

Kernels & Hardware, configuring network, installing services

Problem with Wake-on-Lan settings

Postby mr.rubik » 2017-09-25 20:03


I am struggling with the settings of Wake-On-Lan. Currently, I am pretty stuck.

My configuration is following...

Router: TP-LINK Archer C7
Laptop: Lenovo Thinkpad X1 Carbon 4gen
Server: Dell PowerEdge T30
CellPhone: Samsung Galaxy J7

(I am going to refer to the devices with the shortcuts only (e.g. router, laptop, server, phone))

Server is connected to the router via CAT6 ethernet cable. Laptop is connected to the router either through USB->Ethernet reduction and CAT6 cable as well or via 2GHz WiFi connection. Phone communicates through 2GHz WiFi only.

Server is connected to the power source via Voltcraft 4500 Pro (measure device) and a power cord.

1) Server settings

WoL is enabled in the BIOS settings in Power Management->Wake on Lan.

Server is built upon Debian 9 Stretch, it is very fresh installation, almost nothing else is installed there.

Code: Select all
> ip address
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet brd scope global enp0s31f6
       valid_lft forever preferred_lft forever
    inet6 fe80::4a4d:7eff:feee:282b/64 scope link
       valid_lft forever preferred_lft forever

Code: Select all
> lspci -v
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-LM (rev 31)
        Subsystem: Dell Ethernet Connection (2) I219-LM
        Flags: bus master, fast devsel, latency 0, IRQ 124
        Memory at df000000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: e1000e
        Kernel modules: e1000e

I have used ethtool for setting of Wake-On-Lan:

Code: Select all
> sudo ethtool enp0s31f6
Settings for enp0s31f6:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: on (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

ethtool is configured to start WoL support after startup:

Code: Select all
> cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp0s31f6
allow-hotplug enp0s31f6
#iface enp0s31f6 inet dhcp
iface enp0s31f6 inet static
        post-up /sbin/ethtool -s enp0s31f6 wol g
        post-down /sbin/ethtool -s enp0s31f6 wol g

2) Router is configured to forward UDP ports 9 and 7, the server has static IP (the one you can see above) and the IP binds to the MAC address of the server.
I can provide more details on the router configuration. However, I do not consider it very important (see below).

3) Laptop NIC:

Code: Select all
> lspci -v
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
        Subsystem: Lenovo Device 2233
        Flags: bus master, fast devsel, latency 0, IRQ 129
        Memory at e1200000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: e1000e
        Kernel modules: e1000e

04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
        Subsystem: Intel Corporation Device 0130
        Flags: bus master, fast devsel, latency 0, IRQ 130
        Memory at e1000000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

I send magic packet from laptop. I have tried multiple tools:

Code: Select all
> sudo etherwake -b xx:xx:xx:xx:xx:xx

Code: Select all
> wol -i xx:xx:xx:xx:xx:xx

Code: Select all
> wakeonlan xx:xx:xx:xx:xx:xx

Magic packet was sent through WiFi and Ethernet as well. I even captured the packets with wireshark and checked that I could see the magic packet in the log (I can provide screenshot).

4) I have also tried to send Magic packet from the phone.

As you can guess, any of the mentioned methods wasn't successful. Server is shut down, I just send the magic packet and nothing happens. I installed tshark on the server and captured the packets as well. I could see received magic packets in the log (obviously, on the running machine smile) e.g.:

Code: Select all
15 1.884154644 → WOL 144 MagicPacket for Dell_xx:xx:xx (xx:xx:xot workingx:xx:xx:xx)

Therefore, I suppose that the problem is neither in the sending of Magic packet from laptop, phone or other device nor in routing the packet from the router to the server.

I cannot see any other options in the BIOS settings and I run out of ideas for the OS settings. Is there something I am missing?

Everything is up to date.

Posts: 1
Joined: 2017-09-25 19:55

Re: Problem with Wake-on-Lan settings

Postby Dai_trying » 2017-09-26 04:02

On a machine I used some time back as a server and wanted WOL working I had to configure the BIOS to allow it to happen, have you checked the BIOS settings?
Oops :oops: should have read the end of your post... sorry
Posts: 531
Joined: 2016-01-07 12:25

Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests