[SOLVED] stretch 9.2 update errors

Kernels & Hardware, configuring network, installing services

[SOLVED] stretch 9.2 update errors

Postby ransur0t » 2017-10-07 18:50

Hi folks.

Recent stretch 9.2 update has resulted in errors for :
evolution-common
linux-image-4.9.0-4-amd64

Please see paste:
http://paste.debian.net/989495

Any advice on how to resolve would be greatly appreciated!
Last edited by ransur0t on 2017-10-09 01:09, edited 1 time in total.
User avatar
ransur0t
 
Posts: 7
Joined: 2016-04-06 18:51
Location: Portland, OR

Re: stretch 9.2 update errors

Postby ransur0t » 2017-10-07 20:02

So, running:

Code: Select all
# apt --fix-broken install


a second time successfully removed the kernel update and the linux-image-amd package.

If I try to reinstall linux-image-amd64, I get the following error:
Code: Select all
 linux-image-amd64 : Depends: linux-image-4.9.0-4-amd64 but it is not going to be installed


The issue with evolution-common persists, preventing any system updates or package installations. The problem lies in the /usr/share/help/es/evolution/ directory -- any attempt to --fix-broken results in error: '*dpkg-new': Operation not permitted. I use the * wildcard to indicate that successive attempts point to a seemingly random *dpkg-new file in that directory ...
User avatar
ransur0t
 
Posts: 7
Joined: 2016-04-06 18:51
Location: Portland, OR

Re: stretch 9.2 update errors

Postby stevepusser » 2017-10-07 21:13

How did you upgrade?
Updated Debian 9: 9.2 released press@debian.org wrote:
As a special case for this point release, those using the "apt-get" tool
to perform the upgrade will need to ensure that the "dist-upgrade"
command is used, in order to update to the latest kernel packages. Users
of other tools such as "apt" and "aptitude" should use the "upgrade"
command.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8815
Joined: 2009-10-06 05:53

Re: stretch 9.2 update errors

Postby ransur0t » 2017-10-07 22:55

Thank you for sharing this info. I updated per my usual apt dist-upgrade. :(

Debian Stable Updates Announcement SUA 127-1 email notification that I received -- [SUA 127-1] Upcoming Debian 9 Update (9.2) -- did NOT mention anything to this effect!

Now, how to repair the system ...
User avatar
ransur0t
 
Posts: 7
Joined: 2016-04-06 18:51
Location: Portland, OR

Re: stretch 9.2 update errors

Postby ransur0t » 2017-10-09 01:09

So, I have solved the update error with the evolution-common package by using:
Code: Select all
# dpkg -i --force-all evolution-common_3.22.6-1+deb9u1_all.deb


After the package installed correctly, I successfully reinstalled linux-image-amd64 and the updated kernel 4.9.0-4! :)

For reference (since the paste link expired), the issue I had with evolution-common at the time of upgrade and during any attempt to fix the broken install is listed below:

Code: Select all
apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  evolution-common
The following packages will be upgraded:
  evolution-common
1 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
3 not fully installed or removed.
Need to get 0 B/7,426 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 185662 files and directories currently installed.)
Preparing to unpack .../evolution-common_3.22.6-1+deb9u1_all.deb ...
Unpacking evolution-common (3.22.6-1+deb9u1) over (3.22.6-1) ...
dpkg: error processing archive /var/cache/apt/archives/evolution-common_3.22.6-1+deb9u1_all.deb (--unpack):
 unable to open '/usr/share/help/es/evolution/import-data.page.dpkg-new': Operation not permitted
Errors were encountered while processing:
 /var/cache/apt/archives/evolution-common_3.22.6-1+deb9u1_all.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
User avatar
ransur0t
 
Posts: 7
Joined: 2016-04-06 18:51
Location: Portland, OR


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable