NAS disks powersaving

Kernels & Hardware, configuring network, installing services

NAS disks powersaving

Postby audiolover » 2017-10-08 11:31

I want to configure my NAS that it shuts down for a specific period of the day. The problem is: when I start Debian if the NAS is shutdown, it keeps looking for this NAS as it cannot reconnect to the networkdrives. Is there a setting, for example in FSTAB, to let Debian try once or twice to connect and if it does not succeed to continue with the start-up?
I run Debian Stretch.
audiolover
 
Posts: 24
Joined: 2013-12-22 15:50

Re: NAS disks powersaving

Postby steve_v » 2017-10-09 03:42

You probably want the 'nofail' and 'x-systemd.device-timeout' fstab options.
steve_v
 
Posts: 472
Joined: 2012-10-06 05:31
Location: New Zealand

Re: NAS disks powersaving

Postby audiolover » 2017-10-09 12:11

I am testing a new configuration
in fstab now. Will report results.
audiolover
 
Posts: 24
Joined: 2013-12-22 15:50

Re: NAS disks powersaving

Postby audiolover » 2017-10-09 16:02

I successfully solved the problem bij adding the "nofail" option to fstab. I had to add a "time-out" option to make it work correctly:

192.xxx.xxx.3:/pics /mnt/nas_pics nfs defaults,nofail,x-systemd.device-timeout=1 0 0

Only issue was that by doing this the mountpoint /mnt/nas/pics is no longer "owned" by me as user but owned by ROOT so I had to use CHOWN to correct this.

Now when the NAS is in sleepmode the boottime of my pc is normal, when the NAS is up and running I only need to access the mountpoint, press F5 to renew and hey presto!

Thanks for pointing me in the right direction steve_v!
audiolover
 
Posts: 24
Joined: 2013-12-22 15:50


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable