No service starts after kernel upgrade

Kernels & Hardware, configuring network, installing services

No service starts after kernel upgrade

Postby sarpedon » 2017-10-10 22:31

Good evening (night),

I have searched all over the web and I can't find a solution to my problem. I received an information of my VPS provider saying I should upgrade the kernel because of a hole in LTS version. So I checked different websites and I upgraded the kernel with jessie backports. And when I rebooted, all service were stopped. I was only able to connect with a special console. When I tried to launched for exemple ssh or nginx, it failed and got that error message :

INFO: task (plymouth):3580 blocked for more than 120 seconds
Not tainted + kernel version

I tried to load the old kernel and the same happens.

When I looked at the journalctl after startup, I got these error messages

piix4_smbus smbus host controller not enabled
intel_rapl : no valid rapl domains found in package 0
local-fs.target : dependency failes for Local File Systems

Service 1 has finished shutting down
Service 2 has finished shutting down
..... has finished shutting down

Failed at step EXEC spawning /bin/plymouth : no such file or directory

I think it may be a problem with systemd or Grub but I didn't find a solution.

Thank you for your help if you have an idea.
sarpedon
 
Posts: 3
Joined: 2017-10-10 22:19

Re: No service starts after kernel upgrade

Postby stevepusser » 2017-10-10 23:59

Those websites you found on the web have it exactly backwards. Security fixes will be backported to the the standard Jessie 3.16 kernel sooner that to the jessie-backports kernel. In fact, the backports repo makes no guarantee that any of the packages there will get security fixes.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8938
Joined: 2009-10-06 05:53

Re: No service starts after kernel upgrade

Postby sarpedon » 2017-10-11 06:45

OK, so I just should have waited... Is there a solution ? I also seen that after each command trying to start a service, a "hangup" appears but on the same line of m'y command line.
sarpedon
 
Posts: 3
Joined: 2017-10-10 22:19

Re: No service starts after kernel upgrade

Postby dilberts_left_nut » 2017-10-11 07:02

A lot depends on the virtual hosting environment and you likely need a suitable kernel, not just a generic one.
Probably talking to your provider will be the best way forward.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4703
Joined: 2009-10-05 07:54
Location: enzed

Re: No service starts after kernel upgrade

Postby sarpedon » 2017-10-11 07:16

The problem is that even when I boot on the old kernel, I have this problem. Some people are talking about swap partition. I will check that later.
sarpedon
 
Posts: 3
Joined: 2017-10-10 22:19


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable