primus breaks libgl1-nvidia-glvnd-glx

Kernels & Hardware, configuring network, installing services

primus breaks libgl1-nvidia-glvnd-glx

Postby Pakos » 2017-10-17 14:29

hi,

i'm trying to install primus however it fails at breaking nvidia package,

Code: Select all
The following NEW packages will be installed:
  primus{b} primus-libs{a} primus-libs:i386 primus-libs-ia32:i386{a} socat{a}
0 packages upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
Need to get 478 kB of archives. After unpacking 1,620 kB will be used.
The following packages have unmet dependencies:
 primus : Breaks: libgl1-nvidia-glvnd-glx but 375.82-5 is installed
          Breaks: libgl1-nvidia-glvnd-glx:i386 but 375.82-5 is installed


Am i missing something? I was googling little bit but didn't find any information if it's a bug in primus or something?

(Debian Sid)
User avatar
Pakos
 
Posts: 81
Joined: 2008-03-08 17:36

Re: primus breaks libgl1-nvidia-glvnd-glx

Postby sunrat » 2017-10-18 00:07

I ran into a problem in Sid recently with that libgl1-nvidia-glvnd-glx causing a dist-upgrade to fail. Just removed the package. There were a couple of dependent programs removed so note them and reinstall after. Don't proceed if there are lots of packages to remove.
Then do a full upgrade and cross fingers.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2432
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: primus breaks libgl1-nvidia-glvnd-glx

Postby Pakos » 2018-02-26 15:41

this isn't an update/upgrade, just an fresh install of bumbleebee.
I still cannot install it properly and i have tried that on 2 different laptops with nvidia cards with same result.

Code: Select all
root@baza:~# aptitude install bumblebee-nvidia primus-libs:i386
The following NEW packages will be installed:
  bbswitch-dkms{a} bumblebee{a} bumblebee-nvidia libgl1-nvidia-glvnd-glx{a} libgles-nvidia2{a} libnvidia-cfg1{a} libnvidia-ml1{a}
  libopengl0{a} nvidia-driver{a} nvidia-driver-bin{a} nvidia-driver-libs{a} nvidia-egl-icd{a} nvidia-egl-wayland-icd{a}
  nvidia-kernel-common{a} nvidia-kernel-dkms{a} nvidia-kernel-support{a} nvidia-modprobe{a} nvidia-persistenced{a}
  nvidia-settings{a} nvidia-support{a} nvidia-vdpau-driver{a} primus{ab} primus-libs{a} primus-libs:i386 primus-libs-ia32:i386{a}
  socat{a} xserver-xorg-video-nvidia{a}
0 packages upgraded, 27 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.1 MB/16.2 MB of archives. After unpacking 60.2 MB will be used.
The following packages have unmet dependencies:
 primus : Breaks: libgl1-nvidia-glvnd-glx but 384.111-4 is to be installed
          Breaks: nvidia-driver-libs but 384.111-4 is to be installed
          Breaks: libgl1-nvidia-glvnd-glx:i386 but 384.111-4 is installed
          Breaks: nvidia-driver-libs:i386 but 384.111-4 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     primus [Not Installed]                             

     Leave the following dependencies unresolved:         
2)     bumblebee recommends virtualgl | primus           


Really nobody is using it nowadays? Maybe there is other software right now to get it working?
User avatar
Pakos
 
Posts: 81
Joined: 2008-03-08 17:36

Re: primus breaks libgl1-nvidia-glvnd-glx

Postby stevepusser » 2018-02-26 20:50

Why do you have nvidia-driver 375.82 (Stretch version) in Sid? You should have 384.111. Please explain how this has come about.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9919
Joined: 2009-10-06 05:53

Re: primus breaks libgl1-nvidia-glvnd-glx

Postby sunrat » 2018-02-26 22:12

stevepusser wrote:Why do you have nvidia-driver 375.82 (Stretch version) in Sid? You should have 384.111. Please explain how this has come about.


Maybe no dist-upgrade done in the 4 months since the thread started?
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2432
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: primus breaks libgl1-nvidia-glvnd-glx

Postby Pakos » 2018-02-27 14:39

it is newest, first post is pretty old, previous one shows correct version fo course :)

Code: Select all
root@baza:/home/pakos/Downloads# dpkg -l|grep nvidia-driver
ii  nvidia-driver-libs:i386               384.111-4                           i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-driver-libs-i386:i386          384.111-4                           i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries)
User avatar
Pakos
 
Posts: 81
Joined: 2008-03-08 17:36


Return to System configuration

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable