Debian 9 Gnome : numlockx

Kernels & Hardware, configuring network, installing services

Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-22 09:58

Hello everyone,

It is not my first time that I have installed a debian system and I usually know how to activate numlockx thanks to this documentation but it does not seem to work on Debian 9 Gnome...
Do you know what might have changed between debian 8 and 9?
Thank you for your help!
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby debiman » 2017-10-24 15:39

i don't speak or read french, but "activating" numlockx probably means autostarting it.
you can do that from your user session, startup applications (assuming gnome).
User avatar
debiman
 
Posts: 1519
Joined: 2013-03-12 07:18

Re: Debian 9 Gnome : numlockx

Postby alan stone » 2017-10-24 16:33

I don't use D9, neither gnome, however does this help?
Debian 8.9 32bit, WM: Openbox
Computers are like air conditioners. They work fine until you start opening windows. - Author Unknown
Programming is like sex. One mistake and you have to support it for the rest of your life. - Michael Sinz
User avatar
alan stone
 
Posts: 205
Joined: 2011-10-22 14:08
Location: In my body.

Re: Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-24 20:31

With Debian 8 numlockx worked fine at the logon screen, now with Debian 9 something is new and is not configured in the same way.
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby alan stone » 2017-10-25 03:23

Insofar available, set the numlock through a gnome "keyboard preferences" option related to "numeric keypad keys"?
Debian 8.9 32bit, WM: Openbox
Computers are like air conditioners. They work fine until you start opening windows. - Author Unknown
Programming is like sex. One mistake and you have to support it for the rest of your life. - Michael Sinz
User avatar
alan stone
 
Posts: 205
Joined: 2011-10-22 14:08
Location: In my body.

Re: Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-25 06:58

I created ~/.xprofile and /etc/xprofile with:
Code: Select all
if [ -x /usr/bin/numlockx ]; then
      /usr/bin/numlockx on
fi

and all the other options listed in https://wiki.archlinux.org/index.php/Ac ... _on_Bootup but it does not work...
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby None1975 » 2017-10-25 12:48

f.r3d wrote:Thank you for your help!

Hello. Read this.
OS: Debian 8.9 / WM: xmonad
Debian Wiki | DontBreakDebian
User avatar
None1975
 
Posts: 189
Joined: 2015-11-29 18:23
Location: Lithuania

Re: Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-25 14:53

I created ~/.gnomerc and ~/.xsessionrc with
Code: Select all
if [ -x /usr/bin/numlockx ]; then
      /usr/bin/numlockx on
fi

but numlockx is not activated yet...

I am self-taught in Debian/linux. I have been using it for 8 years but I am not an expert. I have already browsed through documentations and forums, and maybe the solution is somewhere in those documentations but I did not find it because I could not understand it. I did my part of searching but I CAN'T find it.
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby alan stone » 2017-10-25 15:03

You might try one of the methods explained in this video.
Debian 8.9 32bit, WM: Openbox
Computers are like air conditioners. They work fine until you start opening windows. - Author Unknown
Programming is like sex. One mistake and you have to support it for the rest of your life. - Michael Sinz
User avatar
alan stone
 
Posts: 205
Joined: 2011-10-22 14:08
Location: In my body.

Re: Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-25 15:28

It did not work. I tried the 3rd and the 4th methods (the others do not apply to Gnome).
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby debiman » 2017-10-25 16:57

does numlockx work when you execute it manually?

also, what is the output of
Code: Select all
which numlockx


(i sense a triplefacepalm coming on)
User avatar
debiman
 
Posts: 1519
Joined: 2013-03-12 07:18

Re: Debian 9 Gnome : numlockx

Postby f.r3d » 2017-10-25 17:22

Code: Select all
frederic@frederic-laptop:~$ which numlockx
/usr/bin/numlockx


I think numlockx works perfectly, the problem is that GDM does not load it at the login screen.
Debian 9 Gnome 64bits
LDLC Aurore BB5-I3-8-S1 Slim (Clevo W55xEU)
Intel Core i3-3120M / Intel HD Graphics 4000 / RAM 8 Go / Samsung SSD 840 120Go
User avatar
f.r3d
 
Posts: 55
Joined: 2016-07-28 16:39
Location: France

Re: Debian 9 Gnome : numlockx

Postby debiman » 2017-10-25 17:37

have you tried the console options from the archwiki article you linked?

i think your problem is that most advice applies to the X session, but the login manager is not really part of the X session.
so maybe the tty stuff will work.

PS:
https://unix.stackexchange.com/question ... screen-gdm
User avatar
debiman
 
Posts: 1519
Joined: 2013-03-12 07:18

Re: Debian 9 Gnome : numlockx

Postby ruffwoof » 2017-10-25 18:04

apt-get numlockx should install it so that it automatically starts at startup.

Try dpkg-reconfigure numlockx
... and check that /etc/X11/Xession-d/55-numlockx file exists (man page suggests its copied from /usr/share/doc/numlockx/55numlockx). Also try changing /etc/default/numlockx to a value of ON rather than AUTO
ruffwoof
 
Posts: 211
Joined: 2016-08-20 21:00

Re: Debian 9 Gnome : numlockx

Postby furquan » 2017-11-03 12:10

You have to be in an X session for numlockx to work (which you seem to, since it works manually). GDM uses Wayland by default (not sure from which versions onwards), does using the Xorg backend help?

Also: do check if adding a line in /etc/gdm3/Init/Default helps or not.

There's also a very old (~6-7 years) unfixed bug which might be relevant to your situation.
The source code for the kernel, library, etc. should fit on one diskette. Sources for the GNU utilities will vary (and will be big). The sources to GNU emacs will take at least 3 disks. -- Theodore Ts'o, 1992 (distributing the first Linux disks)
User avatar
furquan
 
Posts: 48
Joined: 2017-05-10 11:57
Location: India


Return to System configuration

Who is online

Users browsing this forum: langrad and 8 guests

fashionable