No KernelDriver in Bumblebee.conf?

Kernels & Hardware, configuring network, installing services

No KernelDriver in Bumblebee.conf?

Postby linuxsat » 2017-11-03 08:46

Hello,
I just perform the installation of bumblebee (nvidia version)on my Dell 5480 laptop. I'm on Stretch with kde.
I follow the wiki Since I had some issues in a near past, I tried
Code: Select all
optirun glxgears -info

before attempting to reboot my laptop. It doesen't work and return
Code: Select all
[ERROR]You have not the permission to comunicate with bumblebee daemon. Try adding yourself to the bumblebee group.

Code: Select all
[ERROR]could not connect to bumblebee daemon. Is it running?

Then I checked that I am in the bumblebee group, and that the bumblebee daemon is running. That is ok.

I look in the Bumblebee.conf file and the KerneDriver line is empty. So, I fear to reboot and get a blank screen.
How can I check that the installation of bumblebee is ok?
linuxsat
 
Posts: 5
Joined: 2017-10-20 14:28

Re: No KernelDriver in Bumblebee.conf?

Postby Ardouos » 2017-11-03 11:33

linuxsat wrote:Hello,
I just perform the installation of bumblebee (nvidia version)on my Dell 5480 laptop. I'm on Stretch with kde.

Please tell us what hardware you are using with your laptop? And what version of Debian.

If you are unsure. Please post back the output of:
Code: Select all
lsb_release -a



linuxsat wrote:[ERROR]You have not the permission to comunicate with bumblebee daemon. Try adding yourself to the bumblebee group.

Even if you added yourself to the group, you will need to log out and into the account so the permissions can be applied. Normally if you install Debian through the repos with your account, it adds you into the group automatically.

Type in the terminal
Code: Select all
groups

To check what groups you are currently in and post back the output.

You might need to change in your /etc/bumblebee/bumblebee.conf

Code: Select all
driver=nvidia

and
Code: Select all
KernelDriver=nvidia

You will probably also need to check that bumblebee is looking at your card as it's default is 1:00.00
post the output of:
Code: Select all
lspci | grep "VGA"

If it matches then you will not need to change anything.

linuxsat wrote:I look in the Bumblebee.conf file and the KerneDriver line is empty. So, I fear to reboot and get a blank screen.

AFAIK that shouldnt happen as your laptop is using the intel driver for its primary driver. That should only happen if you have made the mistake of creating an xorg.conf file, hence why the guides tell you not to do it.

If you are uncomfortable with editing files without a graphical environment then I recommend a backup before making any changes.
User avatar
Ardouos
 
Posts: 927
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: No KernelDriver in Bumblebee.conf?

Postby linuxsat » 2017-11-03 13:24

Thanks for your answer,

Please tell us what hardware you are using with your laptop? And what version of Debian.

To be more precise: the Debian version is stretch 9.2, with kde desktiop. Nvidia card is a GeForce 930MX (64 bits).

I had to live my office and II finally reboot the machine. But have to mention for those who had the same
laptop (Dell 4580 with GeForce 930M) that the grub file should be modified if you are installing bumblebee
(otherwise the laptop will not boot:, as I experienced)
add the option
Code: Select all
acpi_rev_override=5

in the line
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT=""

This is dicussed at the end of
https://github.com/Bumblebee-Project/Bumblebee/issues/764

Now I will test if Bumblebee is working properly.
linuxsat
 
Posts: 5
Joined: 2017-10-20 14:28


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable