Automatic RAID array assemblying at boot with Journal

Kernels & Hardware, configuring network, installing services

Automatic RAID array assemblying at boot with Journal

Postby Toxiro » 2017-11-07 13:38


I am running a freshly installed Debian in VMware and I cannot get my RAID array assembled at boot (only if I use the option --write-journal). So the following is working without any issues:

Code: Select all
mdadm --create /dev/md/test --level=5 --raid-devices=3 /dev/sd[bcd]1
/usr/share/mdadm/mkconf > /etc/mdadm/mdadm.conf
update-initramfs -u -k all

If I try the same with a journal device:

Code: Select all
mdadm --create /dev/md/test --level=5 --raid-devices=3 --write-journal=/dev/sde1 /dev/sd[bcd]1

the array gets assembled without any issues, but after the reboot:

Code: Select all
mdadm --detail /dev/md/test
mdadm: cannot open /dev/md/test: No such file or directory

I can get it running manually with:

Code: Select all
mdadm --stop /dev/md127
mdadm --assemble --scan

I tried the same without an mdadm.conf file with the same result: it worked without a journal device, but not with a journal device.
Posts: 2
Joined: 2017-11-07 13:18

Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests