Private internet access app not launching

Kernels & Hardware, configuring network, installing services

Private internet access app not launching

Postby themagicm » 2017-11-11 23:56

[Deb 9 x86 64-bit]

I'm installing the Private Internet access app, v75 under Deb 9 but when I go to run it, the app exits and does not run.

strace on run.sh shows the following towards the end:

Code: Select all
-- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=15382, si_uid=1000, si_status=0, si_utime=3, si_stime=3} ---
rt_sigreturn({mask=[]})                 = 15382
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fa03de659d0) = 15383
wait4(-1, pia_nw: no process found
kill: (15365): No such process
[{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 15383
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=15383, si_uid=1000, si_status=0, si_utime=12, si_stime=4} ---
rt_sigreturn({mask=[]})                 = 15383
read(10, "", 8192)                      = 0
exit_group(0)                           = ?
+++ exited with 0 +++


Thats a vanilla install of Deb 9. Whats interesting is that I have this running under Deb 9 but that version is an upgraded version from Deb 8.

Anyone got this thing to run? I know I can use OpenVPN but the app has features that openvpn does not.
themagicm
 
Posts: 32
Joined: 2011-11-23 06:08

Re: Private internet access app not launching

Postby Bulkley » 2017-11-12 00:18

As an aside, I thought I'd do a little searching for you so I found the Private Internet access app, v75 site. It gives an IP and ISP for me and says that I'm not protected. :lol: They have exit info from my VPN.


Unfortunately I ran into this PIA forum thread.
Unfortunately at this time our systems does not support your operating system, what I would suggest is that you install Openvpn. Here is a article from our support center.


That was a post from July. There is a link at the bottom from someone who got it running on Ubuntu. I suggest you follow the link and others on there. You have lots of company with this problem. My bet is someone has it fixed by now.
Bulkley
 
Posts: 5322
Joined: 2006-02-11 18:35

Re: Private internet access app not launching

Postby themagicm » 2017-11-12 00:36

Yes I found the same unhelpful information you posted and I also regurgitated the same. "use openvpn" which doesnt have features like I stated in the original post.

I'm already using OpenVPN on my pfSense box but I'd rather have a 'VPN kill switch' and some other small features it provides in the app. Maybe one day it will work... lol
themagicm
 
Posts: 32
Joined: 2011-11-23 06:08


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable