SMTP authentication on stretch

Kernels & Hardware, configuring network, installing services

SMTP authentication on stretch

Postby princeofnaxos » 2017-11-20 17:11

Hi,

I run a webserver on stretch. From the website, we send emails with PHPMailer via Postfix. This works very fine without SMTP authentication.

We now need to send our mails with SMTP authentication. I installed sasl2 and configured Postfix, but it refuses to authenticate. I have been trying several configs for three days now, but without any luck.

In /etc/postfix/main.cf, I have added:
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_local_domain = [servername].[mydomain]
smtpd_sasl_path = smtpd
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination


/etc/default/saslauthd:
START=yes
DESC="SASL Authentication Daemon"
NAME="saslauthd"
MECHANISMS="pam"
MECH_OPTIONS=""
THREADS=5
OPTIONS="-c -m /var/run/saslauthd"


I have a /usr/lib/sasl2/smtpd.conf, but it is unclear to me if this file is read:
pwcheck_method: saslauthd 1
mech_list: plain login

I try to authenticate with LOGIN ($mail->AuthType('LOGIN')) with a user that I see in sasldblistuser2, but it just won't do it.

All docs I find on the net seem to handle about jessie and wheezy, and it doesn't match with stretch. I feel like something is off, or missing. It's unclear to me against which password db is matched.

Hope someone can help me.

Edwin
princeofnaxos
 
Posts: 1
Joined: 2017-11-20 14:13

Return to System configuration

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable