ixgbevf help

Kernels & Hardware, configuring network, installing services

ixgbevf help

Postby zey » 2017-11-24 17:40

Disclaimer,

I am a newbie and I am attempting to use Debian within ESXi with SR-IOV enabled.

So I've install Debian without desktop environment as a VM. I have enabled the onboard Intel x557-AT interfaces via pass-through to the Debian VM. I followed the following how-to http://ask.xmodulo.com/download-install-ixgbe-driver-ubuntu-debian.html However it's connected but I still have no link. When I do ip link set ens256 up I get the following

[56.107860] ixgbevf: Unable to start - perhaps the PF Driver isn't up yet RTNETLINK answers: Network is down

Debian 9.2.1
zey
 
Posts: 2
Joined: 2017-11-24 17:32

Re: ixgbevf help

Postby Segfault » 2017-11-24 22:42

This is not a very common case. You should really reveal more information.
Confirmation your hardware and hypervisor support SR-IOV?
Does lspci -nnk show driver loaded?
Anything in dmesg about NIC initialization?
Segfault
 
Posts: 562
Joined: 2005-09-24 12:24

Re: ixgbevf help

Postby zey » 2017-11-25 16:21

As I mentioned I am a newbie. Assume I know nothing.

lspci -nnk

Code: Select all
0b:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection X552 Virtual Function [8086:15a8]
        Subsystem: Super Micro Computer Inc Ethernet Connection X552 Virtual Function [15d9:15ac]
        Kernel driver in use: ixgbevf
        Kernel modules: ixgbevf


Hardware

https://www.supermicro.com/products/motherboard/Xeon/D/X10SDV-7TP4F.cfm

I believe I resolved the issue however.

I now only get RTNETLINK answers: Network is down

My setup is my Supermicro systemboard with Intel x557 SFP attached to my desktop a Chelso 10GB SFP+ adatper using a HP JD097B X240 10G SFP+ 3M DA cable. I have set static IPs on both (10.10.11.2 & 10.10.11.3)

Code: Select all
root@zen:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens224: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0c:29:fb:eb:02 brd ff:ff:ff:ff:ff:ff
    inet 10.10.10.114/24 brd 10.10.10.255 scope global ens224
       valid_lft forever preferred_lft forever
    inet6 fe80::20c:29ff:fefb:eb02/64 scope link
       valid_lft forever preferred_lft forever
3: ens192: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 2a:cb:e5:e5:76:cb brd ff:ff:ff:ff:ff:ff
    inet 10.10.11.3/24 scope global ens192
       valid_lft forever preferred_lft forever
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 02:42:c0:a8:8a:d4 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 scope global docker0
       valid_lft forever preferred_lft forever
root@zen:~# ip link set ens192 up
RTNETLINK answers: Network is down
zey
 
Posts: 2
Joined: 2017-11-24 17:32


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable