Debian upgrade to 8.9 from clone on Intel NUC7i3BNH

Kernels & Hardware, configuring network, installing services

Debian upgrade to 8.9 from clone on Intel NUC7i3BNH

Postby brad103 » 2017-12-01 21:15

Similar to http://forums.debian.net/viewtopic.php?f=5&t=131832

I have a clone image of Debian with some installed & configured services that I clone onto new hardware when needed. The hardware has moved on and is a different model now to in the past. And Debian won't start up, no networking through the onboard NIC and I get left at single user console login.

I have dealt with this on another system previously with an upgrade to 4.9 kernel via jessie-backports to resolve a networking issue (Intel 15d8 (rev 21)).
And on that box to fix the xorg issues I'd uninstalled xserver-xorg-video-intel which resolved it then. But with this box that hasn't worked. I've also tried (from the linked post above):
Code: Select all
apt-get install --target-release jessie-backports xserver-xorg-video-intel libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri
But on this latest upgrade that isn't helping.

# lspci:
Code: Select all
00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
00:08.0 System peripheral: Intel Corporation Device 1911
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Device 9d15 (rev f1)
00:1c.7 PCI bridge: Intel Corporation Device 9d17 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Device 15d8 (rev 21)
3a:00.0 Network controller: Intel Corporation Device 24fd (rev 78)
3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
3c:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a804


# dmesg | grep firmware
Code: Select all
[    3.513775] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-26.ucode (-2)
[    3.513782] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-26.ucode failed with error -2
[    3.513795] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-25.ucode (-2)
[    3.513799] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-25.ucode failed with error -2
[    3.513807] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-24.ucode (-2)
[    3.513811] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-24.ucode failed with error -2
[    3.513820] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-23.ucode (-2)
[    3.513824] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-23.ucode failed with error -2
[    3.513833] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-22.ucode (-2)
[    3.513846] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-22.ucode failed with error -2
[    3.513855] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-21.ucode (-2)
[    3.513858] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-21.ucode failed with error -2
[    3.513867] iwlwifi 0000:3a:00.0: firmware: failed to load iwlwifi-8265-20.ucode (-2)
[    3.513871] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-8265-20.ucode failed with error -2
[    3.520402] i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_01.bin (-2)
[    3.520410] i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_01.bin failed with error -2
[    3.520413] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/intel-linux-graphics-firmwares], disabling runtime power management.
[    3.536148] [drm] GuC firmware load skipped
[    3.974734] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    3.974781] bluetooth hci0: firmware: failed to load intel/ibt-12-16.sfi (-2)
[    3.974800] bluetooth hci0: Direct firmware load for intel/ibt-12-16.sfi failed with error -2
[    3.974805] Bluetooth: hci0: Failed to load Intel firmware file (-2)


I have a USB ethernet dongle for net access while I resolve it.
Don't need wifi working

Thanks
Brad

NUC7i3BNH NUC7i3BNK 7i3BNH 7i3BNK
brad103
 
Posts: 4
Joined: 2013-06-25 10:06

Re: Debian upgrade to 8.9 from clone on Intel NUC7i3BNH

Postby brad103 » 2017-12-12 07:25

Well a Buster (9.2) USB key booted and supported networking, so I moved my installation to Buster and so far so good
brad103
 
Posts: 4
Joined: 2013-06-25 10:06

Re: Debian upgrade to 8.9 from clone on Intel NUC7i3BNH

Postby wyysoft » 2018-02-06 01:57

Hi Brad,
I would like to know whether Intel NUC7i3 supports ASPM L1 and L1.2. I'd appreciate it if you could help me get the info.
The steps may possibly be like:
a) check if ASPM L1 setting is available in BIOS setting
b) if ASPM L1 setting is available, enable it, and
c) boot into Linux OS, and query PCI configuration space of NVMe SSD by typing: sudo lspci -s XX:00.0 -xxxx, where XX is the bus number of the NVMe device

Thanks a lot in advance!
Eric Y.
wyysoft
 
Posts: 1
Joined: 2018-02-06 01:32


Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable