Debian/Linux on Asus ME400C VivoTab Smart

Kernels & Hardware, configuring network, installing services

Debian/Linux on Asus ME400C VivoTab Smart

Postby Xebozone » 2017-12-11 14:09

Hi all,

I got this Windows tablet and wanted to put Linux on it.
I have tried several distros and haven't gotten anywhere.
The only OS I got to boot was RemixOS (by some miracle), but it was extremely slow and unusable, and I believe that's part of the problem, however I don't know why, and I'm unsure of what RemixOS does specially that would load a UI as opposed to the other attempts.

The device has an Intel Atom Cloverdale CPU and a 32-bit UEFI. Windows 8 and Windows 10 run on it just fine (although a bit slowly).
The goal is to get Android on here, but at this point, I'm just looking to boot into a usable linux terminal.

I've installed rEFInd on the tablet, an EFI shell and GRUB. They all work fine and at full speed (as to be expected).
As soon as the linux kernel loads, that's a different story.

The latest I've tried is to install Debian on a VM with VirtualBox (within Windows on the device, setting BIOS type to EFI).
I then mounted the VHD in Windows and used MiniTool to clone the ext partition to the actual device's storage.
I then booted into grub, manually set the root as my partition, and the prefix as partition/boot/grub , insmod normal and then run normal.
Grub loads the menu and I can attempt to boot.

If I try to boot normally, I wait several minutes for things to start moving...
Then I get a sea of text from the kernel (before systemd has loaded, I believe... no fancy checks).
Then everything stops and slowly the screen draws black covering the top of the screen to the bottom (it takes about 30 minutes for this to happen)... and then nothing, even after waiting hours.

I have tried to boot into recovery/rescue mode just then.
I've left it for about 6 hours now... and I'm still waiting.

From what I can see, when Linux is running, everything is just super-slow...
When booting into recovery/rescue mode from grub, it hung on "loading initial ramdisk" for a good 10 minutes.

I tried to mount the partition in Windows with Ext2FS to get the logs, however it doesn't seem to understand the partition for some reason...

Some screenshots attached:
Any assistance would be lovely... as I've just about given up. Any kernel flags I can try setting?
Posts: 2
Joined: 2017-12-11 13:31

Re: Debian/Linux on Asus ME400C VivoTab Smart

Postby tynman » 2017-12-11 17:14

According to this, your computer has 2 GB of RAM. That may be a bit sparse to run Windows 8, but as you say it runs (slowly).

Trying to run a guest system on it using VirtualBox might be expected to fail by run out of memory?
Posts: 86
Joined: 2016-05-03 19:48
Location: British Columbia, Canada

Re: Debian/Linux on Asus ME400C VivoTab Smart

Postby pylkko » 2017-12-11 19:48

I don't think he wants to virtualize the OS, just to install to the bare metal from the VM?

Anyway, did you use a specially crafted linux image? Which Debian image are you using. Because, as you probably know, there were these Atom "Bay Trail" tablets with Microsoft InstaGo, which was so buggy that they had to use a 32-bit firmware only with a 64bit OS. So, AFAIK, still to this day, if you want to install Linux distributions on them you need to use a specially crafted 32bit UEFI bootloader? Did you do this? Or maybe you can use a multiarch Debian? Can you post any of the contents of the output prior to it failing?

Here is a thread about, I believe your hardware, where Debian kernel developer Ben Hutchings gives some insight on the problems related to these tablets: ... 00004.html

read the resposes
User avatar
Posts: 1365
Joined: 2014-11-06 19:02

Re: Debian/Linux on Asus ME400C VivoTab Smart

Postby Xebozone » 2017-12-12 00:13

Thanks for your responses.
It is much appreciated. I did not use a specially crafted image. I used the standard netboot x86 image available on the Debian downloads page.
The GRUB that I use in the UEFI came with this image.

I will make another attempt later to see if I can mount the partition and grab some of the logs.
I did read through Ben's notes, however I noticed that he was able to get the kernel to load... for me, it seems that the kernel won't even load.
I have hope :)
Posts: 2
Joined: 2017-12-11 13:31

Re: Debian/Linux on Asus ME400C VivoTab Smart

Postby pylkko » 2017-12-12 21:14

google upd asus me400c and 32bit efi grub

there are people that have done it. If my memory suites me there was even an unofficial Fedora image that had everything ready in it.
User avatar
Posts: 1365
Joined: 2014-11-06 19:02

Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests