userspace governor in debian 4.9

Kernels & Hardware, configuring network, installing services

userspace governor in debian 4.9

Postby kmahmou1 » 2017-12-16 04:29

Hi,

I have a debian " Debian 4.9.51-1".
In /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governor , I can only see : performance and powersave.
How can I enable the userspace governor ?

I tried to add "intel_pstate=disable" to GRUB config but it's still not working.
Does Debian 4.9.51-1 support it ?

Thanks
kmahmou1
 
Posts: 3
Joined: 2017-12-16 04:20

Re: userspace governor in debian 4.9

Postby bw123 » 2017-12-16 09:13

A nice package called cpufrequtils helped me with a similar issue.
User avatar
bw123
 
Posts: 2931
Joined: 2011-05-09 06:02
Location: TN_USA

Re: userspace governor in debian 4.9

Postby wizard10000 » 2017-12-16 09:55

kmahmou1 wrote:Hi,

I have a debian " Debian 4.9.51-1".
In /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governor , I can only see : performance and powersave.
How can I enable the userspace governor ?

I tried to add "intel_pstate=disable" to GRUB config but it's still not working.
Does Debian 4.9.51-1 support it ?


I'm afraid you can't get there even with intel_pstate disabled. Check this out -

https://www.kernel.org/doc/html/v4.12/a ... state.html

edit: for clarification, pstate's performance and powersave governors are not the same governors the cpufreq driver uses. They have the same names but that's about it.
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1268
Joined: 2011-05-09 20:02
Location: everywhere i go, there i am!

Re: userspace governor in debian 4.9

Postby kmahmou1 » 2017-12-16 20:22

Hi,

That article is very useful and covers almost everything.
According to what I understood, in order to enable all governors, intel_pstate has to be set to passive.
I did this, rebooted and it did not work :(.

However, I really think the CPU supports setting a specific frequency, but the driver seems not to allow that.
Inspecting the values of scaling_cur_freq, I can clearly see different values in there every time I "vim".

My CPU is : Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz.
Any additional ideas ?
kmahmou1
 
Posts: 3
Joined: 2017-12-16 04:20

Re: userspace governor in debian 4.9

Postby kmahmou1 » 2017-12-21 20:12

Putting intel_pstate=disable in the /etc/default/grub is enough.
However, you should run "update-grub" to reflect that in the grub configuration file.
kmahmou1
 
Posts: 3
Joined: 2017-12-16 04:20

Re: userspace governor in debian 4.9

Postby Segfault » 2017-12-21 20:21

Why not use the more advanced P states driver? It won't be loaded if your CPU does not support it. Why userspace?
Segfault
 
Posts: 664
Joined: 2005-09-24 12:24


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable