Wifi router keeps disconnecting when I browse the web

Kernels & Hardware, configuring network, installing services

Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 18:44

Hello,

I have two laptops, one has Windows and the other has Debian 9, recently installed. On Debian, the wifi keeps disconnecting whenever a webpage is loading, but I noticed that the other laptop looses the connection at the same time. Based on other posts on the same problem, I have tried to set 11n_disable=1 with the commands below, but that didn't help.

Code: Select all
modprobe -r iwldvm
modprobe -r iwlwifi
modprobe iwlwifi 11n_disable=1
modprobe iwldvm


My linux skills are very limited and I can't seem to make this work on my own. Your help would be appreciated.

Thanks!
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby Bulkley » 2017-12-16 18:58

Since both laptops are losing the Wifi connection it is more likely to be a router/modem or an ISP problem. As to the router/modem look here. Is Your Wireless Connection Dropping? The article may look simple but it has some good points.

Did you know that some Wifi equipment is directional? I once solved Wifi dropping in my house by turning the router 90 degrees. Another time I found that my two closest neighbours were using the same channel.

Something to think about. Are the laptops made by the same manufacturer? If so, do they use the same mini Wifi card? Do a Net search to see if they are a problem. When new, my laptop dropped Wifi to the point that out of frustration I swapped the Wifi card for one of another make and have never had a problem since. Those things aren't perfect. They are also not expensive.
Bulkley
 
Posts: 5397
Joined: 2006-02-11 18:35

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 19:16

My laptops are both Lenovo and they use the same network adapter model. However, my phone also looses wifi connectivity when the laptops are being disconnected.

Maybe I should mention, the two laptops have no issues when both are running Windows. Also, Debian stays connected indefinitely as long as I don't make traffic (browse any webpage, even google).
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby arochester » 2017-12-16 19:27

I wonder if this is a problem with Lenovo.

(Writing this from a Lenovo laptop.)

I need to register my interest in finding a solution.

My workaround is to use the wifi as long as it works and to use a dongle when it doesn't...
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN." - oswaldkelso
arochester
 
Posts: 1142
Joined: 2010-12-07 19:55

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 19:33

arochester wrote:My workaround is to use the wifi as long as it works and to use a dongle when it doesn't...

So, you are saying you have issues on your laptop and use the above workaround? Or is that a suggestion for me to try?
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby bw123 » 2017-12-16 19:54

dobre.dani wrote:My laptops are both Lenovo and they use the same network adapter model. However, my phone also looses wifi connectivity when the laptops are being disconnected.

Maybe I should mention, the two laptops have no issues when both are running Windows. Also, Debian stays connected indefinitely as long as I don't make traffic (browse any webpage, even google).


Sounds awful, when you access the network from the debian machine it drops everything off? Does the router reboot or what, and do they reconnect or does it take some kind of reset?
User avatar
bw123
 
Posts: 2600
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 20:04

bw123 wrote:
dobre.dani wrote:Does the router reboot or what, and do they reconnect or does it take some kind of reset?


It looks like the router has a reset due to a traffic spike or something. All wireless devices will loose connection and reconnect in 10-15 seconds.
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby bw123 » 2017-12-16 20:12

I read this the other day. not sure I understand what happens with the 11n_ and other settings but if you're up to experiment it looks pretty safe and easy to undo?


viewtopic.php?f=10&t=135573&sid=6fc74af8e2b92b0d22199d35cb0e74b8#p660918

also, make sure you goto the wiki page for iwlwifi, on a well-trained browser, usually just type in
debian wiki iwlwifi
User avatar
bw123
 
Posts: 2600
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 20:59

bw123 wrote:I read this the other day. not sure I understand what happens with the 11n_ and other settings but if you're up to experiment it looks pretty safe and easy to undo?


viewtopic.php?f=10&t=135573&sid=6fc74af8e2b92b0d22199d35cb0e74b8#p660918

also, make sure you goto the wiki page for iwlwifi, on a well-trained browser, usually just type in
debian wiki iwlwifi


With the settings below in iwlwifi.conf, my wifi connection was dropping regularly, with no action from me.
Code: Select all
options iwlwifi led_mode=1 power_save=0 11n_disable=8 swcrypto=1

After changing 11n_disable to 1, the wifi behaves as before (stays connected to wifi if no traffic is made, breaks when there is traffic)
Code: Select all
options iwlwifi led_mode=1 power_save=0 11n_disable=1 swcrypto=1


I have followed the steps in https://wiki.debian.org/iwlwifi#Installation with no luck.

BTW, Debian was installed over the internet, with the smaller iso on an usb (debian-9.3.0-amd64-netinst.iso) and everything else downloaded. So, the connection should work, in theory!
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby bw123 » 2017-12-16 21:59

Some routers have a setting to limit how many devices are allowed? Are they all set to use dhcp? Also, what happens if the debian machine is the only one connected?
User avatar
bw123
 
Posts: 2600
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-16 22:45

bw123 wrote:Some routers have a setting to limit how many devices are allowed? Are they all set to use dhcp? Also, what happens if the debian machine is the only one connected?


Both laptops are using dhcp.

Debian acts up as always, even if it's the only one connected. The other devices' behavior is relevant in pinpointing the source of the wifi crash, which would be the router, not the Debian machine itself. Debian is causing the router to crash though!
It is strange that Debian downloaded a lot of data during the installation, while the other laptop was connected to wifi with no issues, but after the installation was complete, wifi was not readily available. I had to setup wifi manually (don't remember how I did it).

More on the installation process:
As I remember, network could not be set up using the base package (debian-9.3.0-amd64-netinst.iso), so I had a second USB containing firmware-iwlwifi_0.43_all.deb plugged in. After installation, the wireless card was not listed (lspci) so I think (not sure) I have installed the package above (firmware-iwlwifi_0.43_all.deb).
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby Bulkley » 2017-12-16 23:13

dobre.dani wrote:Maybe I should mention, the two laptops have no issues when both are running Windows. Also, Debian stays connected indefinitely as long as I don't make traffic (browse any webpage, even google).


That sounds like a driver problem. Some drivers work well with Windows but their Linux equivalent behaves badly.

Are you sure that you have the correct non-free firmware?
Bulkley
 
Posts: 5397
Joined: 2006-02-11 18:35

Re: Wifi router keeps disconnecting when I browse the web

Postby dobre.dani » 2017-12-17 12:50

I am not sure of anything, as I am not experienced with linux. Maybe I will reinstall Debian and see what happens. Or quit trying...
dobre.dani
 
Posts: 9
Joined: 2017-12-16 18:27

Re: Wifi router keeps disconnecting when I browse the web

Postby bw123 » 2017-12-17 12:58

dobre.dani wrote:firmware-iwlwifi_0.43_all.deb plugged in. After installation, the wireless card was not listed (lspci) so I think (not sure) I have installed the package above (firmware-iwlwifi_0.43_all.deb).


might be worth a try at using the stretch version instead of jessie?

https://packages.debian.org/search?keywords=iwlwifi
User avatar
bw123
 
Posts: 2600
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Wifi router keeps disconnecting when I browse the web

Postby Segfault » 2017-12-17 13:49

Lets use some logic on this. The access point stops functioning. To me it tells something is wrong with it. There is no way a normally functioning access point could lock up like this when a client connects.
Does this access point have some logs to look at?
Have you tried to go elsewhere and connect to a different wireless access point?
Is it the router that locks up or the access point?
Segfault
 
Posts: 590
Joined: 2005-09-24 12:24

Next

Return to System configuration

Who is online

Users browsing this forum: awachens and 5 guests

fashionable