no internetconnection Sid after reboot (SOLVED)

Kernels & Hardware, configuring network, installing services

no internetconnection Sid after reboot (SOLVED)

Postby username2 » 2017-12-24 18:38

I'm to new to Debian/Linux to figure it out. Searched and tried all day to get my internet connection working again but can't get it fixed.

I've read and tried so many possibilities that i'm completely lost now. Because i have no internet i can't post all my codes.

This is how it looks wright now. Can some off you help me out?

ip adress:
Code: Select all
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 27.0.0.1/8 scope host lo valid lft preferred lft forever
inet6 ::1/128 scope host valid lft preferred lft forever
2: enp5s0: <BROADCAST, MULTICAST, UP,LOWER_UP>   *******
Inet 192.168.1.97/24 BRD 192.168.1.255 scope global enp5s0  valid lft preferred lft forever
*****
*****
3: wlp2s0: BROADCAST, MULTICAST> mtu *******
***********


sudo lshw -C network: (top network was still DISABLED at my the last lshw check, no idea why it has changed now but inet still not working). Wireless status doesn't change by using wireless on/off switch on laptop
Code: Select all
*-network (was at first DISABLED)
       description: Ethernet interface
       product: ***********
       vendor: **********
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: enp5s0
       version: c0
       serial: *******
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=ATL1C driverversion=1.0.1.6 duplex=full firmware=L1e ip=192.168.1.97 la

*-network DISABLED
       description: Wireless interface
       product: *****
       vendor: ******
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wpl2s0
       version: 01
       serial: *****
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical wireless   
       configuration: *****


interface file
Code: Select all
# The loopback network interface
auto lo
iface lo inet loopback


Changed IP adress to 192.168.1.97 to see if this solution worked. Didn't but have no idea what orininal IP adress was :(
https://ubuntuforums.org/showthread.php?t=2018113

route -n:
Code: Select all
route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0        0.0.0.0         255.255.255.0   U     0      0        0 enp5s0


i can ping 127.0.0.1 and 192.168.1.97, can't ping router or other laptop on hub (network onreachable)
Last edited by username2 on 2017-12-26 18:18, edited 1 time in total.
username2
 
Posts: 13
Joined: 2017-12-09 15:15


Re: no internetconnection Sid after reboot

Postby username2 » 2017-12-24 19:44

systemctl --failed
Code: Select all
UNIT                     LOAD   ACTIVE SUB  DESCRIPTION
nmbd.service        loaded failed failed Samba NMB Daemon
virtualbox.service loaded failed failed LSB: Virtualbox Linux kernel module


hmmm, i've tried to remove virtualbox before reboot so that could be the trigger. Thanks

now i can try to figure out what to do next
username2
 
Posts: 13
Joined: 2017-12-09 15:15

Re: no internetconnection Sid after reboot

Postby username2 » 2017-12-25 10:26

Nice to have a couple of days off, but not to sit behind your computer to find a solution for my connection problem :(
Read and tried so many different possible sollutions, none seems to be working for me
Also tried to install networkmanager/Gnome/**, but get errors because of no internet connection
I'm stuck wright now, need some advise what to do or where to look for

ifconfig gives:
Code: Select all
enp5s0 flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
   inet 192.168.2.7 netmask 255.255.255.0 broadcast 192.168.2.255
   inet6 fe80::****
   inet6 2a02:a****
   ether 70:71:bc:****
   RX packets 652 ****
   RX errors 0 dropped 0 overrun 0 frame 0
   TX packets 507 ****
   TX errors 0 dropped 0 overruns 0 carrier 1 collision 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
   inet 127.0.0.1 netmask 255.255.255.0
   inet6 ::1 prefixlen 128 ****
   loop tsqueelen 1000 ****
   RX packets 69120 ****
   RX errors 0 ****
   TX packets 69120 ****
   TX errors 0 ****

wlp2s0 flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
   ether 48:5d:60:81:96:20 ****
   RX packets 0 0000
   RX errors 0 ****
   TX packets 0 ***
   TX errors 0 ****
wlp2s0: avahi: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
   inet 169.254.6.153 netmask 255.255.0.0 broadcast 169.254.255.255
   ether 48:5d:60:81:96:20 ****


iwconfig gives:
Code: Select all
wlp2s0 IEEE 802.11 ESSID: off/any
   mode:Managed Acces Point: Not Associated Tx-Power=0
   Retry Short Limit:7 RTS thr:off Fragment thr:off
   Encryption key:off
   Power Managemet:off
lo   no wireless connection
enp5s0   no wireless connection


ping "myrouter" -c 1 -s 1400 -M do gives:
Code: Select all
PING myrouter 1400(1428) bytes of data
1408 bytes from myrouter: icmp seq=1 ttl=64 time=0.702 ms
1 packet transmitted, 1 recieved, 0% loss
rtt min/avg/max/mdev = 0.702/0.702/****
'

ping "myrouter" -c 1 -s 1520 -M do
Code: Select all
PING myrouter 1501(1529) bytes of data
ping: local error: Message to long, mtu=1500
1 packet transmitted, 0 recieved, +1 errors, 100% loss


ping localhost gives:
Code: Select all
PING localhost (localhost (::1) 56 data bytes
*******
9 packets transmitted, 9 recieverd, 0% loss


etc/network/interfaces was:
Code: Select all
auto lo
iface lo inet loopback

I added:
Code: Select all
auto enp5s0
iface enp5s0 inet static
   adress 127.00.1
   netmask 255.255.255.0
   gateway 192.168.2.254

auto enp5s0
allow-hotplug enp5s0
iface enp5s0 inet dhcp


and changed managed in etc/NetworkManager/NetworkManager.conf from false to true:
Code: Select all
[main]
plugins=ifupdown,keyfile
[ifupdown]
managed=true
username2
 
Posts: 13
Joined: 2017-12-09 15:15

Re: no internetconnection Sid after reboot

Postby Segfault » 2017-12-25 10:41

Code: Select all
auto enp5s0
iface enp5s0 inet static
   adress 127.00.1
   netmask 255.255.255.0
   gateway 192.168.2.254

The static address you gave to it is not valid.
Segfault
 
Posts: 664
Joined: 2005-09-24 12:24

Sid networking

Postby llivv » 2017-12-25 17:37

networking typically runs automagically out of the box. If your having issues connecting you could be missing package(s) that are required per your installation.
clue: put the quoted text at the top of your
Code: Select all
/etc/network/interfaces
where it should be/have been in the first place.
/etc/network/interfaces wrote:# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
# /usr/share/doc/ifupdown/examples for more information.
in the kitchen with Julia
The Past, Christmas Present and Future
Get on the Dbus to Bcan
User avatar
llivv
 
Posts: 5614
Joined: 2007-02-14 18:10
Location: cold storage

Re: no internetconnection Sid after reboot

Postby username2 » 2017-12-25 20:01

Segfault wrote:
Code: Select all
auto enp5s0
iface enp5s0 inet static
   adress 127.00.1
   netmask 255.255.255.0
   gateway 192.168.2.254

The static address you gave to it is not valid.


sorry, is 127.0.0.1. Have to type everything because of no inet on other laptop
username2
 
Posts: 13
Joined: 2017-12-09 15:15

Re: no internetconnection Sid after reboot

Postby Head_on_a_Stick » 2017-12-25 20:16

username2 wrote:is 127.0.0.1

That's still the wrong address.

https://en.wikipedia.org/wiki/Localhost
Charlie don't hack
User avatar
Head_on_a_Stick
 
Posts: 7660
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: no internetconnection Sid after reboot

Postby username2 » 2017-12-26 18:17

Oke, changed it to 192.168.1.97 and the wired connection works

Finaly got wireless also working again.

Thanks for all yout help
username2
 
Posts: 13
Joined: 2017-12-09 15:15


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable