Debian Gnome Flickers

Kernels & Hardware, configuring network, installing services

Debian Gnome Flickers

Postby GonzaloP » 2018-01-05 05:12

Hi,

For the last couple of weeks I have been experiencing a flickering in the screen, I checked the logs and I am getting:

Code: Select all
[drm:gen8_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun


I am running Debian 9 and the VGA is VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

Looking for a solution I found that it seems to be a common problem related to the "AccelMethod" parameter.

How can I change the "AccelMethod" I couldn't find the configuration file.

Thanks
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby Head_on_a_Stick » 2018-01-05 06:32

GonzaloP wrote:
Code: Select all
[drm:gen8_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

That's interesting, I'm seeing the same errors in my OpenBSD system since they upgraded to Xorg 1.19.5; no flickering though :)

GonzaloP wrote:I am running Debian 9 and the VGA is VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

Have you tried removing xserver-xorg-video-intel?

Have you added firmware-misc-nonfree?

Use an Xorg configuration file to force the AccelMethod but I don't think that is the issue here — jessie defaulted to UXA so switching to SNA gave a significant boost, stretch defaults to SNA but the Intel DDX driver is now discouraged by Debian in favour of Xorg's builtin modesetting driver.
"Men are born ignorant, not stupid. They are made stupid by education." — Bertrand Russell
User avatar
Head_on_a_Stick
 
Posts: 7189
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian Gnome Flickers

Postby yeti » 2018-01-05 07:42

I see a probably similar flickering with Stretch on a Thinkpad-510 (1600x900 display) and `dmesg` shows lots of the following lines:
Code: Select all
[336200.037408] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[336200.037456] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

Sometimes even the graphics collapses to a black screen, sometimes with some flickering pixels only at the "leftest" side. This may happen less than once a week and sometimes multiple times a day and so far I don't see a usage pattern triggering this.
"They may have computers, and other weapons of mass destruction." — Janet Reno
"Logic, my dear Zoe, merely enables one to be wrong with authority." — The 2nd Doctor
"Don't we all wait for SOMETHING-ELSE-1.0?" — yeti
User avatar
yeti
 
Posts: 41
Joined: 2009-03-30 14:22
Location: Wrong Planet.

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-05 08:41

Yeti, nice to share the pain with you. I am experiencing the same, the problem started for me around 1 week ago as well.

yeti wrote:I see a probably similar flickering with Stretch on a Thinkpad-510 (1600x900 display) and `dmesg` shows lots of the following lines:
Code: Select all
[336200.037408] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[336200.037456] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

Sometimes even the graphics collapses to a black screen, sometimes with some flickering pixels only at the "leftest" side. This may happen less than once a week and sometimes multiple times a day and so far I don't see a usage pattern triggering this.
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby Wheelerof4te » 2018-01-05 09:16

viewtopic.php?f=5&t=135567

Note that in the light of the Meltdown and Spectre, running an unpatched, older kernel will pose a major security risk. Try to disable 3D animations in GNOME instead.
User avatar
Wheelerof4te
 
Posts: 656
Joined: 2015-08-30 20:14

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-05 12:40

Hi,

Thanks for the answer. I did installed firmware-misc-nonfree but I did not remove the xserver-xorg-video-intel. Don't I need that driver to run X?


Head_on_a_Stick wrote:
GonzaloP wrote:
Code: Select all
[drm:gen8_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

That's interesting, I'm seeing the same errors in my OpenBSD system since they upgraded to Xorg 1.19.5; no flickering though :)

GonzaloP wrote:I am running Debian 9 and the VGA is VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

Have you tried removing xserver-xorg-video-intel?

Have you added firmware-misc-nonfree?

Use an Xorg configuration file to force the AccelMethod but I don't think that is the issue here — jessie defaulted to UXA so switching to SNA gave a significant boost, stretch defaults to SNA but the Intel DDX driver is now discouraged by Debian in favour of Xorg's builtin modesetting driver.
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby Wheelerof4te » 2018-01-05 13:03

GonzaloP wrote: but I did not remove the xserver-xorg-video-intel. Don't I need that driver to run X?


No, you don't if you use Intel iGPU from 2008. onwards. Newer cards will use modesetting (i915 kernel driver). I don't think firmware package will help, honestly.
User avatar
Wheelerof4te
 
Posts: 656
Joined: 2015-08-30 20:14

Re: Debian Gnome Flickers

Postby Bulkley » 2018-01-05 16:06

Kernel 4.9.0-5 came down for Stable last night. Does that help?
Bulkley
 
Posts: 5435
Joined: 2006-02-11 18:35

Re: Debian Gnome Flickers

Postby Wheelerof4te » 2018-01-05 16:32

^
For the stable distribution (stretch), this problem has been fixed in version 4.9.65-3+deb9u2

No, since it is the same 4.9.65 version that contains the bug. Only later upstream version will fix it.
User avatar
Wheelerof4te
 
Posts: 656
Joined: 2015-08-30 20:14

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-06 15:09

It doesn't, I just tried, and when I opened the console everything freezes.

Bulkley wrote:Kernel 4.9.0-5 came down for Stable last night. Does that help?
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-06 16:43

Any other idea on how to solve this issue? I've tried all what was suggested and it didn't work out.
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby dcihon » 2018-01-06 17:13

dcihon
 
Posts: 138
Joined: 2012-09-23 16:18

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-07 04:35

I to /etc/environment the line:

Code: Select all
CLUTTER_PAINT=disable-clipped-redraws:disable-culling


And it just makes it worst. Still I couldn't find a solution for this.
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Re: Debian Gnome Flickers

Postby Wheelerof4te » 2018-01-08 13:06

There isn't a solution. Only option is to use another kernel that doesn't have that problem. Or wait with an outdated, insecure kernel for Debian 9.4.
User avatar
Wheelerof4te
 
Posts: 656
Joined: 2015-08-30 20:14

Re: Debian Gnome Flickers

Postby GonzaloP » 2018-01-08 15:20

So, this problem has been reported already?

Thanks
Wheelerof4te wrote:There isn't a solution. Only option is to use another kernel that doesn't have that problem. Or wait with an outdated, insecure kernel for Debian 9.4.
GonzaloP
 
Posts: 16
Joined: 2015-10-23 17:13

Next

Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable