Broadcom BCM4352 WL Drivers

Kernels & Hardware, configuring network, installing services

Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 17:18

Hello everyone. I upgraded my packages today as per usual and now Debian won't detect my wireless interface. I'm running Debian Stretch on a Dell XPS 13 9343 (4.14.0-3-amd64 #1 SMP Debian 4.14.12-2 (2018-01-06) x86_64 GNU/Linux [the output of "uname -a"]).

Output of lspci (for the network controller):

02:00.0 Network controller: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter (rev 03)

The output of "sudo ifconfig" is

Code: Select all
enx00e04c6800a3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 128.54.128.245  netmask 255.255.240.0  broadcast 128.54.143.255
        inet6 fe80::2e0:4cff:fe68:a3  prefixlen 64  scopeid 0x20<link>
        ether 00:e0:4c:68:00:a3  txqueuelen 1000  (Ethernet)
        RX packets 116073  bytes 85262774 (81.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 11038  bytes 1118786 (1.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 448  bytes 29748 (29.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 448  bytes 29748 (29.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


where enx00e04c6008a3 is my wired connection.

"sudo iwconfig" shows the above interfaces and both are missing the usual wireless interface.
rfkill list only shows my bluetooth (whereas it usually also shows my wireless).

At first, I tried doing "modprobe wl" and it outputted:
modprobe: FATAL: Module wl not found in directory /lib/modules/4.14.0-3-amd64
so I tried reinstalling broadcom-sta-common and broadcom-sta-source
(from the Debian non-free sources listed below:
deb http://ftp.us.debian.org/debian/ sid main non-free
deb-src http://ftp.us.debian.org/debian/ sid main non-free)
now modprobe outputs:

Code: Select all
modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='wl'
modprobe: ERROR: could not insert 'wl': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running install command for wl
modprobe: ERROR: could not insert 'wl': Operation not permitted

I found a thread for Ubuntu with a similar problem: https://askubuntu.com/questions/845279/ ... s-broadcom
and tried to do "dpkg -P broadcom-sta-common" and "dpkg -P broadcom-sta-source" then replaced my non-free sources with:
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free
but I still get the same output.

Here are the versions of broadcom-sta-common and broadcom-sta-source that I have:

Code: Select all
dpkg -l broadcom-sta-common && dpkg -l broadcom-sta-source
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  broadcom-sta-c 6.30.223.271 all          Common files for the Broadcom STA
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  broadcom-sta-s 6.30.223.271 all          Source for the Broadcom STA Wirel



I apologize if my format is incorrect (I am new here). Thank you for all who help!
Last edited by Tachycardia on 2018-01-08 18:29, edited 2 times in total.
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59

Re: Broadcom BCM4352 WL Drivers

Postby bw123 » 2018-01-08 17:48

I'm running Debian Stretch on a Dell XPS 13 9343 (I think that the kernel is 4.14.0-3-amd64


That is odd, I didn't think the 4.14 was availabkle for stretch yet, did yo get it from stretch-backports or compile it yourself or what?

uname -a will give you some more info

Code: Select all
replaced my non-free sources with:
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free


Why in the world would you do that?

Maybe if you post your sources.list and apt-cache policy output some people on here can help you sort it out. Alos, I think I saw a forum post or two lately about that device, so search the forum.

good luck!
Last edited by bw123 on 2018-01-08 17:52, edited 1 time in total.
User avatar
bw123
 
Posts: 2587
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 17:52

I don't think that I backported, since I haven't been screwing with anything lately: just normal sudo apt-get update and sudo apt-get upgrade stuff.

As for the non-free sources, I needed them for the Dell XPS 13 9343 as per this guide:
https://wiki.debian.org/InstallingDebia ... 013%209343

I thought that perhaps the packages were incorrect so I wanted to try a different source.

(Output of uname -a: 4.14.0-3-amd64 #1 SMP Debian 4.14.12-2 (2018-01-06) x86_64 GNU/Linux)
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59

Re: Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 17:54

Here's my apt-get policy output:

Code: Select all
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://repo.steampowered.com/steam precise/steam i386 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=i386
     origin repo.steampowered.com
 500 http://repo.steampowered.com/steam precise/steam amd64 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=amd64
     origin repo.steampowered.com
 500 https://repo.skype.com/deb stable/main amd64 Packages
     release o=. stable,a=stable,n=stable,l=. stable,c=main,b=amd64
     origin repo.skype.com
 500 http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid/main i386 Packages
     release o=Metasploit Framework,n=lucid,l=Metasploit Framework,c=main,b=i386
     origin downloads.metasploit.com
 500 http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid/main amd64 Packages
     release o=Metasploit Framework,n=lucid,l=Metasploit Framework,c=main,b=amd64
     origin downloads.metasploit.com
 500 http://deb.debian.org/debian stretch/main i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/main amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org stretch/updates/non-free i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org stretch/updates/contrib i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org stretch/updates/main i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.de.debian.org/debian stretch/non-free i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=i386
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian stretch/non-free amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian stretch/main i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian stretch/main amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.de.debian.org
 500 http://ftp.us.debian.org/debian stretch-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=i386
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin ftp.us.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.us.debian.org/debian stretch/main i386 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
     release v=9.3,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.us.debian.org
Pinned packages:
     metasploit-framework -> 4.16.31+20180108113943~1rapid7-1 with priority 1000

My sources.list:

Code: Select all
deb http://ftp.us.debian.org/debian/ stretch main
deb-src http://ftp.us.debian.org/debian/ stretch main
deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main
# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main
deb-src http://ftp.us.debian.org/debian/ stretch-updates main
deb http://ftp.de.debian.org/debian stretch main non-free

#deb http://ftp.us.debian.org/debian/ sid main non-free
#deb-src http://ftp.us.debian.org/debian/ sid main non-free
#deb http://httpredir.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free


Thanks!
Last edited by Tachycardia on 2018-01-08 18:29, edited 1 time in total.
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59

Re: Broadcom BCM4352 WL Drivers

Postby bw123 » 2018-01-08 17:58

Tachycardia wrote:I don't think that I backported, since I haven't been screwing with anything lately: just normal sudo apt-get update and sudo apt-get upgrade stuff.

As for the non-free sources, I needed them for the Dell XPS 13 9343 as per this guide:
https://wiki.debian.org/InstallingDebia ... 013%209343

I thought that perhaps the packages were incorrect so I wanted to try a different source.

(Output of uname -a: 4.14.0-3-amd64 #1 SMP Debian 4.14.12-2 (2018-01-06) x86_64 GNU/Linux)


https://wiki.debian.org/InstallingDebia ... 013%209343
NOTE: If you upgrade the kernel to 4.1.4 or higher, the wl module will not compile anymore. Instead, install and compile broadcom-sta-source from stretch.


Sounds odd, take your time and you'll probably figure it out. I thought at first your msg said you used some sid pkgs, so if you did, let people know. It will save wasted time.

Instead of *replacing* contrib and non-free sources with stretch/updates you should probably *add* it, so add the non-free and contrib back to stretch main source and see if that helps.
User avatar
bw123
 
Posts: 2587
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 18:10

Sorry, I'm not too sure what you mean by that. Would I just take say

Code: Select all
deb http://ftp.de.debian.org/debian stretch main non-free


and just change it to

Code: Select all
deb http://ftp.de.debian.org/debian stretch main non-free contrib
?

(And yeah, I used sid packages since the XPS installation guide said to. Honestly wasn't sure what it meant, but googling it now, it says that it's unstable so perhaps that's why I'm having this problem?)
Last edited by Tachycardia on 2018-01-08 18:36, edited 1 time in total.
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59

Re: Broadcom BCM4352 WL Drivers

Postby bw123 » 2018-01-08 18:15

Tachycardia wrote:
deb http://ftp.de.debian.org/debian stretch main non-free contrib?

(And yeah, I used sid packages since the XPS installation guide said to. Honestly wasn't sure what it meant, but googling it now, it says that it's unstable so perhaps that's why I'm having this problem?)


yeah, leave the 'main non-free contrib' in place for both stretch and stretch/updates

Sid is going to be a mess for you to maintain, and those ubuntu repos too
User avatar
bw123
 
Posts: 2587
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 18:20

Okay, so my sources.list looks like this now:

Code: Select all
deb http://ftp.us.debian.org/debian/ stretch main
deb-src http://ftp.us.debian.org/debian/ stretch main
deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main
# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main
deb-src http://ftp.us.debian.org/debian/ stretch-updates main
deb http://ftp.de.debian.org/debian stretch main contrib non-free


So I ran:
Code: Select all
apt-get install --reinstall broadcom-sta-common broadcom-sta-source
service network-manager restart
modprobe wl


the latter which outputted the same output:

Code: Select all
modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='wl'
modprobe: ERROR: could not insert 'wl': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running install command for wl
modprobe: ERROR: could not insert 'wl': Operation not permitted
Last edited by Tachycardia on 2018-01-08 18:30, edited 1 time in total.
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59

Re: Broadcom BCM4352 WL Drivers

Postby bw123 » 2018-01-08 18:25

there are some basics you might be missing? you always have to update after changing sources.list you should probably read the don't break debian link, and also just slow down a little in general and read before you do anything. It really helps.

https://wiki.debian.org/DontBreakDebian

and use code boxes or Garry will post a long message telling you how to use code boxes. sheesh. (j/k Garry)
User avatar
bw123
 
Posts: 2587
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Broadcom BCM4352 WL Drivers

Postby Tachycardia » 2018-01-08 18:35

Yeah, I guess I do kind of need to slow down. I'm just kind of in a rush since I'm doing this while I have classes (I'll probably break from this for said classes, but it'd be nice to have your help in a few hours afterwards).

I fixed the code boxes (sorry Garry).

So I tried the previous steps with apt-get update, but I still have the same result.
I hope I didn't really break my install by using the sid sources. I've had those since I first installed Debian a few months ago, but I didn't realize that was a testing repo :/.

I found another similar thread for Parrot: https://community.parrotsec.org/viewtopic.php?id=368
which was fixed when the person upgraded so I'm guessing that maybe some updates incompatible with the broadcom packages that I had were pushed out? Things were working yesterday, but after I updated today things stopped working.
Tachycardia
 
Posts: 6
Joined: 2018-01-08 16:59


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable