Manually mount USB

Kernels & Hardware, configuring network, installing services

Manually mount USB

Postby czeekaj » 2018-01-09 10:31

I was wondering, as I am new to linux in general
I dislike the USB auto mounting when I plug it in.
Is there a way to make sure it only mounts drives that I select as the user? I see some USB mount programs but I not sure how to go about disabling automounting and finding the proper daemon to mount the USB manually.
Thanks.
still having trouble with it, can't find anything in my specific case and a replacement if I disable it.
I am using XFCE Desktop on Debian 9 Stretch. I not sure what if any daemons are out there that can make it seemless to mount without manually mounting in terminal everytime. If anyone knows it would be much appreciated.
I am pretty new to linux I started on Raspbian wheezy so I have kinda a bias for Debian based Systems. However, I am trying out streatch for the first time and now it's up and running I am trying to tweak it to something I would enjoy using daily.

This looks okay but not sure how if it's in the repository. I have set up now I will update If I figure it out.
https://usbmount.alioth.debian.org/
I wan't it on the interface to make it easy as a user so this Pmount package seems Ideal.
https://packages.debian.org/search?keywords=pmount
czeekaj
 
Posts: 14
Joined: 2018-01-09 10:18

Re: Manually mount USB

Postby bw123 » 2018-01-09 15:50

czeekaj wrote:IThis looks okay but not sure how if it's in the repository. I have set up now I will update If I figure it out.
https://usbmount.alioth.debian.org/
I wan't it on the interface to make it easy as a user so this Pmount package seems Ideal.
https://packages.debian.org/search?keywords=pmount


I tried usbmount on stretch and I could not get it to work, I decided to use package autofs on my plain fluxbox machine.

On xfce4 I am not sure, but it probably uses udisks2. I also use KDE and it has a system settings panel where you can enable automount for devices, but they are all set to notify only by default. If you can't find a way to control automount on xfce4 like this, maybe you could list your devices in fstab with the 'noauto' flag, or there may be another flag that applies. udisks2 seems to be compatible with this method for me, I use it to force mount thru udisks to a specific place instead of the /media/<username> or UUID folder..
User avatar
bw123
 
Posts: 2625
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Manually mount USB

Postby czeekaj » 2018-01-10 11:40

I still have automount enabled and unsure how to disable it. Under terminal on Taskmanager I see Udisksd --no-debug
czeekaj
 
Posts: 14
Joined: 2018-01-09 10:18

Re: Manually mount USB

Postby Seventh » 2018-01-10 11:45

Code: Select all
sudo mount /dev/sdx1 /mnt


sdx1 is the partition you are mounting, check with lsblk. Could be sdx1 sdx2 etc. The x denotes a letter, usually a,b,c,d depending on how many storage devices you have connected with a particular accepted filesytem.

if using thunar create a shortcut to /mnt

You dont need bloat to access your drives.

Udevil is also another great little program with no bloat.
Seventh
 
Posts: 44
Joined: 2017-04-01 10:13

Re: Manually mount USB

Postby None1975 » 2018-01-10 15:07

Seventh wrote:You dont need bloat to access your drives.Udevil is also another great little program with no bloat.

Have in dependencies udisks2...
OS: Debian 9.3 / WM: Herbstluftwm
Debian Wiki | DontBreakDebian, Herbstluftwm
User avatar
None1975
 
Posts: 266
Joined: 2015-11-29 18:23
Location: Lithuania

Re: Manually mount USB

Postby pcalvert » 2018-01-12 16:35

czeekaj wrote:I dislike the USB auto mounting when I plug it in.
Is there a way to make sure it only mounts drives that I select as the user? I see some USB mount programs but I not sure how to go about disabling automounting and finding the proper daemon to mount the USB manually.

Here's a hint:

Settings > Removable Drives and Media > Storage [tab]


Phil
pcalvert
 
Posts: 1756
Joined: 2006-04-21 11:19
Location: Sol Sector

Re: Manually mount USB

Postby czeekaj » 2018-01-15 05:01

by default they were all unchecked when I looked but now It's bit nicer I have to right click to mount.
When I plug in a USB it's there but not mounted. I guess I disabled this 'feature' great now I don't have to worry about the windows file systems as much either :) I at three boots now lol.
My bad kind a rookie at this. It was auto mounting but yeah, I don't even have to do in command line. XFCe seems to do it for me. Thank you !
czeekaj
 
Posts: 14
Joined: 2018-01-09 10:18


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable