[SOLVED] firmware: failed to load ar3k/AthrBT_0x00000200.dfu

Kernels & Hardware, configuring network, installing services

[SOLVED] firmware: failed to load ar3k/AthrBT_0x00000200.dfu

Postby JMGama » 2018-01-10 22:00

firmware: failed to load ar3k/AthrBT_0x00000200.dfu (-2)

Hi I'm using debian 9 in my MSI GS60 2QE and i cant use the Bluetooth, looks like there is a problem with the ar3k firmware.
I already install the firmware-atheros

Kernel: 4.9.0-5-amd64
Debian 9

Here whe see the info with the next command
Code: Select all
dmesg | grep -i bluetooth

Code: Select all
[    8.338645] Bluetooth: Core ver 2.22
[    8.338660] Bluetooth: HCI device and connection manager initialized
[    8.338663] Bluetooth: HCI socket layer initialized
[    8.338665] Bluetooth: L2CAP socket layer initialized
[    8.338673] Bluetooth: SCO socket layer initialized
[    8.605326] Bluetooth: Loading patch file failed
[   22.969895] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   22.969896] Bluetooth: BNEP filters: protocol multicast
[   22.969898] Bluetooth: BNEP socket layer initialized
Last edited by JMGama on 2018-01-11 05:48, edited 1 time in total.
Posts: 2
Joined: 2018-01-10 21:46

Re: firmware: failed to load ar3k/AthrBT_0x00000200.dfu (-2)

Postby stevepusser » 2018-01-11 01:04

Possibly it is related this MSI problem on Ubuntu that throws the same message: https://bugs.launchpad.net/ubuntu/+sour ... ug/1542743

Turns out to be an error by Qualcomm for the device ID that requires torturous workarounds.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.13 kernel, wine-staging 4.0~rc4, Stellarium 0.18.3, VLC 3.0.5, Midori 7.0
User avatar
Posts: 10433
Joined: 2009-10-06 05:53

[SOLUTION] firmware: failed to load ar3k/AthrBT_0x00000200.d

Postby JMGama » 2018-01-11 05:47

Just install this deb module and seems to work perfect!!

The error steal showing at the dmesg log, but the bluetooth device is working perfectly.
You can see more about this problem at this link:
Posts: 2
Joined: 2018-01-10 21:46

Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests