Ctrl+Alt+Shift detected as Ctrl+Alt in textadept

Kernels & Hardware, configuring network, installing services

Ctrl+Alt+Shift detected as Ctrl+Alt in textadept

Postby jmyette » 2018-01-30 01:29

Hi,

When using the textadept text editor, keyboard shortcuts involving the Shift key don't work because the Shift key is somehow not detected. For example Ctrl+Alt+Shift+H is detected as Ctrl+Alt+H. Otherwise the Shift key by itself is working as expected.

However I noticed that I have this issue only with the English (US) keyboard layout. If I switch to the French (Canada) layout, for example, all shortcuts work as expected.

I made a lot of searches but couldn't find a solution. I also updated my system from Debian 8.10 to 9.3 but no luck. Any idea where the shift key could be intercepted? Suggestions where I could dig?

Here is my setup:
Debian 9.3
Mate desktop environment 1.16.2
i3 window manager 4.13
textadept text editor 9.6

Thanks for any help.
jmyette
 
Posts: 2
Joined: 2018-01-30 01:07

Re: Ctrl+Alt+Shift detected as Ctrl+Alt in textadept

Postby Thorny » 2018-01-30 08:04

jmyette wrote:However I noticed that I have this issue only with the English (US) keyboard layout. If I switch to the French (Canada) layout, for example, all shortcuts work as expected.

I don't have a clue about textadept. And, I don't have a clue if it might be related to your window manager.

You might check that, /etc/default/keyboard, is correct for your keyboard.

You might try dumpkeys (as root) in the two layouts and compare them to see if there is a difference.

After that, I've run out of guesses. Maybe someone will come along later who can shed more light on the issue.
User avatar
Thorny
 
Posts: 542
Joined: 2011-02-27 13:40

Re: Ctrl+Alt+Shift detected as Ctrl+Alt in textadept

Postby jmyette » 2018-01-30 18:52

Thanks for your suggestions Thorny. I made a few more tests:

- /etc/default/keyboard looks ok
- dumpkeys outputs the same for both layouts
- same issue with MATE's default window manager, so not an issue with window manager
- same issue with XFCE, so not an issue with desktop environment

However if I change the order of the layouts in the keyboard preferences, the issue disappears with the English layout but appears with the French layout. Said otherwise, no problem with the first layout in the list, only with the second. (I use only two layouts.)

At this point I still don't know if the issue is with the keyboard configuration or with textadept, but at least I have a workaround since I use textadept mostly with the English layout.

Thanks again.
jmyette
 
Posts: 2
Joined: 2018-01-30 01:07

Re: Ctrl+Alt+Shift detected as Ctrl+Alt in textadept

Postby Thorny » 2018-01-31 12:29

jmyette wrote:However if I change the order of the layouts in the keyboard preferences, the issue disappears with the English layout but appears with the French layout. Said otherwise, no problem with the first layout in the list, only with the second. (I use only two layouts.)

Thanks again.

Oui, it seems like you have done your homework and I wish I could help further. The only other thing I could think of would be if you are using a multi-lingual keyboard (shows both English and French characters on the keys) and maybe XKBMODEL in the configuration file is not what the system has chosen as default.

Maybe someone who knows more will come along and inform us both.

It's good you have found a solution that will work for for the way in which you use your system. You are welcome!

[edit ]Calice! I just found something that might be worth reading.
https://www.x.org/releases/X11R7.5/doc/ ... onfig.html
Bonne chance!
User avatar
Thorny
 
Posts: 542
Joined: 2011-02-27 13:40


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable