[SOLVED] nginx issue (I think)

Kernels & Hardware, configuring network, installing services

Re: nginx issue (I think)

Postby debiman » 2018-02-12 06:02

dcihon, how did you configure nginx?
did you edit anything in /etc/nginx?
User avatar
Posts: 3064
Joined: 2013-03-12 07:18

Re: nginx issue (I think)

Postby dcihon » 2018-02-23 17:10

The problem was in this file:

The line:
listen = /var/run/php-fpm.sock
needed to be:
listen = /var/run/php-fpm.socket

The error was shown in the nginx error.log file:
2018/02/23 09:19:05 [crit] 9067#9067: *2 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client:, server: _, request: "GET /mail/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "dccathome.com"

I will mark this solved.
Thanks everyone for your help.
The answer finally came from iredmail support.
Posts: 233
Joined: 2012-09-23 16:18


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests