Disable Suspend/Sleep/Hybernate Debian 9 stretch *Solved*

Kernels & Hardware, configuring network, installing services

Disable Suspend/Sleep/Hybernate Debian 9 stretch *Solved*

Postby Derpbian » 2018-02-14 08:00

Hello.

I would like know if it is possible to be able to close the lid/lock the screen without the computer going down into "sleep mode". I have tried to follow this guide

https://wiki.debian.org/Suspend

However, it seems to only be for earlier versions of debian. I have tried to modify the /etc/systemd/logind.conf file:

-----
[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=ignore
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%
-----

Am I missing something or have I done something wrong? I've tried to search the forums for a resolution to this. I am also kind of new to Debian so sorry if there is a thread regarding this issue.

BR.
Last edited by Derpbian on 2018-02-16 20:42, edited 1 time in total.
su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46

Re: Disable Suspend/Sleep/Hybernate Debian 9 stretch

Postby wizard10000 » 2018-02-14 11:12

Code: Select all
#HandleLidSwitch=ignore
#HandleLidSwitchDocked=ignore


This is exactly the right syntax but the # in front of these two lines says that this is a comment and would be ignored by logind. Remove the # from these two lines and you should be golden.

Good luck -
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1285
Joined: 2011-05-09 20:02
Location: everywhere i go, there i am!

Re: Disable Suspend/Sleep/Hybernate Debian 9 stretch

Postby Derpbian » 2018-02-14 11:44

wizard10000 wrote:
Code: Select all
#HandleLidSwitch=ignore
#HandleLidSwitchDocked=ignore


This is exactly the right syntax but the # in front of these two lines says that this is a comment and would be ignored by logind. Remove the # from these two lines and you should be golden.

Good luck -


Thank you very much! :D
su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46


Return to System configuration

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable