problem setting up wifi/adhoc (3 laptops)

Kernels & Hardware, configuring network, installing services

problem setting up wifi/adhoc (3 laptops)

Postby b606 » 2018-02-14 13:12

Hi,
I have three laptops that I want to connect occasionnally in adhoc mode, all with up to date debian stretch :
laptop A : kernel 4.9.0-5-amd64, KF5 plasma-network-manager, firewall ufw, Intel Wireless 8260 (rev 3a)
laptop B : kernel 4.9.0-5-686, KF5 plasma-network-manager, atheros AR9285, no firewall
laptop C : kernel 4.9.0-5-686, LXDE/Openbox, nm-applet, Intel Wireless 3945, no firewall

wifi work perfectly on all for accessing the internet, even using a mobile phone shared access point.

B (192.168.0.2) and C (192.168.0.3) can connect to each other using adhoc (simple configuration in the respective network manager applets, with WEP128 key for testing purpose), they can ping, ssh and sync files.

Problem:

1- A cannot join the same SSID network as ip 192.168.0.1. A and B have the same plasma-nm applet gui, so there should not be a misconfiguration issue. plasma-network-manager seems to spit out errors in /var/log/daemon.log :
Code: Select all
Feb 14 13:40:06 linux-xxxx wpa_supplicant[6234]: wlan0: Trying to associate with SSID 'MYSSID'
Feb 14 13:40:06 linux-xxxx wpa_supplicant[6234]: wlan0: Association request to the driver failed
Feb 14 13:40:06 linux-xxxx wpa_supplicant[6234]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="MYSSID" auth_failures=3 duration=30 reason=CONN_FAILED


2- I tried manual configuration on A, after stopping network manager (service NetworkManager stop) using the instructions at https://wiki.debian.org/WiFi/AdHoc without success.
Code: Select all
iwconfig wlan0 channel auto essid MYSSID mode ad-hoc key s:XXXXXXXXXXXX

Laptop A cannot ping B or C. 'ifconfig wlan0' shows
Code: Select all
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.1  netmask 255.255.255.0  broadcast 192.168.0.255
        etc.

iwlist wlan0 scan on A seemingly shows that it is on the same cell as the other laptops
Code: Select all
iwlist wlan0 scan | grep -B5 -A13 MYSSID
          Cell 35 - Address: A2:38:83:C7:C3:C9
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=-26 dBm 
                    Encryption key:on
                    ESSID:"MYSSID"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Ad-Hoc
                    Extra:tsf=0000000011bf2941
                    Extra: Last beacon: 188ms ago
                    IE: Unknown: 0005414C494B41
                    IE: Unknown: 010882040B160C121824
                    IE: Unknown: 030101
                    IE: Unknown: 06020000
                    IE: Unknown: 32043048606C
                    IE: Unknown: 7F0800000A0200000040
                    IE: Unknown: DD070050F202000100


Why is adhoc working out of the box on laptop B and C, and not on A ? is there a limitation on the number of PC in adhoc mode ? What am I missing at this point ?
b606
 
Posts: 2
Joined: 2018-02-14 12:19

Re: problem setting up wifi/adhoc (3 laptops)

Postby shep » 2018-02-15 15:20

Your notes indicate that Laptop A also has a firewall enabled while B & C do not.

You could test by temporarily disabling the firewall.
shep
 
Posts: 215
Joined: 2011-03-15 15:22

Re: problem setting up wifi/adhoc (3 laptops)

Postby b606 » 2018-02-15 15:44

I tested to disable ufw firewall without success (through 'kcmshell4 ufw'). As my setup is by default Deny incoming, I also tested allowing broadcast module.
I cannot identify what specific service do I have to open for wifi/adhoc to work.
FYI : I have some firewall blocking msg but only from one of the other laptop (UDP blocked port 8612 & 8610)
Code: Select all
dmesg
[ 4958.279717] [UFW BLOCK] IN=wlan0 OUT= MAC= SRC=fe80:0000:0000:0000:f2d5:bfff:feb4:7bb1 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=49429 PROTO=UDP SPT=8612 DPT=8612 LEN=24
[ 4958.279778] [UFW BLOCK] IN=wlan0 OUT= MAC= SRC=fe80:0000:0000:0000:f2d5:bfff:feb4:7bb1 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=703664 PROTO=UDP SPT=8612 DPT=8610 LEN=24
[ 4958.289973] [UFW BLOCK] IN=wlan0 OUT= MAC= SRC=fe80:0000:0000:0000:f2d5:bfff:feb4:7bb1 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=49429 PROTO=UDP SPT=8612 DPT=8612 LEN=24
[ 4958.289983] [UFW BLOCK] IN=wlan0 OUT= MAC= SRC=fe80:0000:0000:0000:f2d5:bfff:feb4:7bb1 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=703664 PROTO=UDP SPT=8612 DPT=8610 LEN=24
b606
 
Posts: 2
Joined: 2018-02-14 12:19


Return to System configuration

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable