[Solved] persistent apt-get update error

Kernels & Hardware, configuring network, installing services

[Solved] persistent apt-get update error

Postby hypatia » 2018-02-22 20:49

For about the last 6 weeks apt-get update generated the following error message:

E: Failed to fetch http://security.debian.org/dists/stretc ... slation-en Could not open file /var/lib/apt/lists/partial/security.debian.org_dists_stretch_updates_main_i18n_Translation-en.bz2 - open (13: Permission denied) [IP: 128.101.240.215 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Searched online for a solution to this problem:

rm /var/lib/apt/lists/partial/*

Now when I run apt-get update the following error message is generated:

E: Failed to fetch http://security.debian.org/dists/stretc ... slation-en BZ2_bzread: /var/lib/apt/lists/partial/security.debian.org_dists_stretch_updates_non-free_i18n_Translation-en.bz2 Read error (-5: DATA_ERROR_MAGIC)

This would suggest a corrupt file on the debain update server but this seems very unlikely to me.


Repos: Active apt sources in file: /etc/apt/sources.list.d/antix.list
deb http://iso.mxrepo.com/antix/stretch/ stretch main
Active apt sources in file: /etc/apt/sources.list.d/debian-stable-updates.list
deb http://debian.mirror.netelligent.ca/debian/ stretch-updates main contrib non-free
Active apt sources in file: /etc/apt/sources.list.d/debian.list
deb http://debian.mirror.netelligent.ca/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/mx.list
deb http://iso.mxrepo.com/mx/repo/ stretch main non-free

Does anyone know what the problem is and how to resolve it.

Sandy
Naturally nuts no pharmaceuticals required ...
Last edited by hypatia on 2018-02-23 17:26, edited 1 time in total.
hypatia
 
Posts: 5
Joined: 2018-02-22 14:24

Re: persistent apt-get update error

Postby Thorny » 2018-02-22 21:11

Does it work any better if you try to fetch:
http://security.debian.org/dists/stretc ... ion-en.bz2 from a different mirror?
User avatar
Thorny
 
Posts: 542
Joined: 2011-02-27 13:40

Re: persistent apt-get update error

Postby hypatia » 2018-02-23 16:13

Thank you for your reply Thorny.

Would you be able to suggest a alternative (mirror) for :

deb http://security.debian.org/ stretch/updates main contrib non-free


Sandy
Naturally nuts no pharmaceuticals required
hypatia
 
Posts: 5
Joined: 2018-02-22 14:24

Re: persistent apt-get update error

Postby hypatia » 2018-02-23 17:25

I've been able to solve the problem.

Initially I only deleted the files in the partial directory.

Removing everything in /var/lib/apt/lists, including the partial directory solved the problem.

Tom
Naturally nuts no pharmaceuticals required
hypatia
 
Posts: 5
Joined: 2018-02-22 14:24


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable
cron