Prevent stretch from updating hwclock on shutdown

Kernels & Hardware, configuring network, installing services

Prevent stretch from updating hwclock on shutdown

Postby hypatia » 2018-02-26 22:11

I would like to prevent stretch from updating my systems hardware clock on shutdown.

You can read the specific reason for wanting to make this change here:

https://forum.mxlinux.org/viewtopic.php?f=104&t=43771

The suggestion of editing /etc/init.d/hwclock.sh (remove 0 6) does not work.

Any advice on how to accomplish this task would be greatly appreciated.

Sandy
Naturally nuts no pharmaceuticals required ...
hypatia
 
Posts: 5
Joined: 2018-02-22 14:24

Re: Prevent stretch from updating hwclock on shutdown

Postby sunrat » 2018-02-26 22:34

Are you dual-booting Windows? It will reset time unless you set Windows to use UTC or Linux to use local time.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2321
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Prevent stretch from updating hwclock on shutdown

Postby hypatia » 2018-02-26 22:52

Yes I am dual booting with Windows sunrat ... linux has been set to use local time.

The error message "Superblock last mount time in the future. (less than a day)"
appears on startup even if I don't boot to Windows for weeks at a time.

Don't think it's a hardware clock problem.
Jessie is installed on the same system and hard drive and no error message on reboot.

If I leave the system turned off for several hours no error message is generated on system startup.

Thank you for your suggestion sunrat.

Sandy
Naturally nuts no pharmaceuticals required ...
hypatia
 
Posts: 5
Joined: 2018-02-22 14:24

Re: Prevent stretch from updating hwclock on shutdown

Postby bw123 » 2018-02-27 01:08

I'm confused by the details, and the link to the other forum doesn't make it clear what the problem is? You are using three, not dual installations, win, jessie and stretch? What does MX have to do with it? If the error happens when you boot stretch, why do you want to fix it by changing the way stretch shuts down?

I think you should take it easy trying any more edits or commands from the net until you figure out better what to do. Be sure and make backups.

Also, when you say, "linux has been set to use local time." do you mean both jessie and stretch were told not to use UTC in the installer? Did you change any other settings on either or both linux systems?

The only time I recall seeing msg like that about time set in the future is after changing the time myself in the bios. It usually goes away after the next shutdown, IIRC.
User avatar
bw123
 
Posts: 3075
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Prevent stretch from updating hwclock on shutdown

Postby debiman » 2018-02-27 06:33

hypatia wrote:You can read the specific reason for wanting to make this change here:

https://forum.mxlinux.org/viewtopic.php?f=104&t=43771

The suggestion of editing /etc/init.d/hwclock.sh (remove 0 6) does not work.

isn't that advice specific to sysvinit?
and stretch uses systemd, which either doesn't execute that at all, or overrides it with its own hardware clock service?
just guessing...
User avatar
debiman
 
Posts: 2396
Joined: 2013-03-12 07:18


Return to System configuration

Who is online

Users browsing this forum: scouser and 8 guests

fashionable