Internet not working, Qualcom Atheros

Kernels & Hardware, configuring network, installing services

Re: Internet not working, Qualcom Atheros

Postby vanbynight » 2018-04-02 14:02

shep wrote:
# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address 210.110.83.32
netmask 255.255.255.0
network 210.110.83.0
broadcast 210.110.83.255
gateway 210.110.83.1

dns-nameservers 202.30.44.11


Network interface naming changed with the full implementation of systemd in Debian 9.

From this Arch wiki:https://wiki.archlinux.org/index.php/Network_configuration

Network interfaces

For computers with multiple NICs, it is important to have fixed interface names. Many configuration problems are caused by interface name changing.

udev is responsible for assigning names to each device. Systemd uses Predictable Network Interface Names, which automatically assigns static names to network devices. Interfaces are now prefixed with en (wired/Ethernet), wl (wireless/WLAN), or ww (WWAN) followed by an automatically generated identifier, creating an entry such as enp0s25.
Get current interface names

Both wired and wireless interface names can be found via ls /sys/class/net or ip link


All you have to do is replace eth0 with the new name for the interface. Your new /etc/network/interfaces file should look like such:


Code: Select all
# The primary network interface
allow-hotplug ens34
iface ens34 inet static
address 210.110.83.32
netmask 255.255.255.0
network 210.110.83.0
broadcast 210.110.83.255
gateway 210.110.83.1

dns-nameservers 202.30.44.11


Systemd changed the predictable interface names to names that won't change if you add or remove hardware. It's not very helpful on desktops with a single interface but it makes setting up and maintaining systems with many interfaces easier.

This works because if you run

Code: Select all
ifconfig -a


it lists your ethernet as ens34 not eth0 as it did in old timey debian
vanbynight
 
Posts: 4
Joined: 2018-03-30 17:10

Re: Internet not working, Qualcom Atheros

Postby krjames » 2018-04-06 08:12

"All you have to do is replace eth0 with the new name for the interface. Your new /etc/network/interfaces file should look like such:"
That's what I was hoping but not so far.
Here's the output I get now;

/etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
#auto lo
#iface lo inet loopback
allow-hotplug ens34
iface ens34 inet static
address 210.110.83.32
netmask 255.255.255.0
network 210.110.83.0
broadcast 210.110.83.255
gateway 210.110.83.1

dns-nameservers 202.30.44.11

Find the network interface name
ens34 lo

check for internet connectivity
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=40 time=57.1 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 57.161/57.161/57.161/0.000 ms


--- 210.110.83.32 ping statistics ---
414 packets transmitted, 414 received, 0% packet loss, time 422471ms
rtt min/avg/max/mdev = 0.010/0.032/0.047/0.004 ms

From # ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens34: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 10:78:d2:2e:5f:1e brd ff:ff:ff:ff:ff:ff
inet 210.110.83.32/24 brd 210.110.83.255 scope global ens34
valid_lft forever preferred_lft forever
inet6 fe80::1278:d2ff:fe2e:5f1e/64 scope link
valid_lft forever preferred_lft forever

I did try lspci -v to confirm the atl1c driver (which we already knew) and ;
ip link show dev ens34 which showed that the driver(module) was working..

Not sure if the ping results mean anything useful at all.

Cheers
James
krjames
 
Posts: 29
Joined: 2006-06-19 00:16
Location: South Korea

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable