hplip qt dependencies

Kernels & Hardware, configuring network, installing services

hplip qt dependencies

Postby patrick013 » 2018-03-14 17:23

hplip-3.18.3.run (runs from command line)

Have the above package from HP for Debian install of current HP
data and drivers. Also the old Debian package hplip installed
via Synaptic version 3.16.11

Can't resolve some errors installing version 3.18.3 - installed a number of
qt packages but am not hitting the right ones. Anyone know which packages
hplip requires per below ? Thanks.

Missing REQUIRED dependency: pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))

error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
patrick013
 
Posts: 84
Joined: 2013-02-07 19:08

Re: hplip qt dependencies

Postby stevepusser » 2018-03-14 19:18

As far as I know, you need either the Qt 5 or the Qt 4 packages...so the Qt4 versions are python-qt4 and python-qt4-dbus. The upstream Debian 3.18.3 package builds against Qt 5 and Python 3, and has these build-depends for those:
Code: Select all
               pyqt5-dev-tools,
               python3-dev,
               python3-dbus,
               python3-gi,
               python3-pyqt5


Though it may also have patches to help with a python3 build...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, tlp-ui, wine-staging 3.21, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10268
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable