Problems with a samba sharing folder

Kernels & Hardware, configuring network, installing services

Problems with a samba sharing folder

Postby dam034 » 2018-04-14 18:36

Dear users,

in my LAN server I have samba to share in LAN the files.

All folders/sharings created until yesterday are working correctly. Today I created a new folder in my filesystem and a new sharing in samba:
Code: Select all
root@myserver:/srv/folders# ls -ahl
drwxrwxr-x  8 peter  admin 4,0K mar 22 12:31 .
drwxr-xr-x 11 root     root  4,0K mar 22 17:28 ..
drwxrwx--- 30 retropie admin 4,0K mar 23 17:17 retropie
drwxrwxrwx  2 peter  admin 4,0K mar 23 17:19 writing
drwxrwxr-x  3 peter  admin 4,0K feb  1 17:00 service
drwxrwxr-x  7 peter  admin 4,0K mar 23 17:21 temporary

I want to specify the user peter is member of admin group.
This is smb.conf:
Code: Select all
[retropie]
available = yes
browseable = yes
path = /srv/folders/retropie
read only = no
public = yes
create mask = 0770
directory mask = 0770

[writing]
available = yes
browseable = yes
path = /srv/folders/writing
read only = no
public = yes
create mask = 0777
directory mask = 0777

[service]
available = yes
browseable = yes
path = /srv/folders/service
read only = no
public = yes
create mask = 0775
directory mask = 0775

[temporary]
available = yes
browseable = yes
path = /srv/folders/temporary
read only = no
public = yes
create mask = 0775
directory mask = 0775


As you can see, "temporary" and "service" are read-only folders, in "writing" any user can write, but the problems there are in "retropie".

I want to restrict the access in that folder according with the 770 permissions, then the user "retropie" and the member users of "admin" can login with their password and read/write.

When on a client in LAN I try to mount the folder, I get this error:
Code: Select all
root@retropie:/tmp# mount -t cifs //192.168.1.2/retropie roms -o username=retropie,password=mypw,dir_mode=0777,file_mode=0777,iocharset=utf8
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Where did I wrong?

Please help!
dam034
 
Posts: 1
Joined: 2018-04-14 18:29

Re: Problems with a samba sharing folder

Postby kevinthefixer » 2018-05-13 02:17

dam034 wrote:When on a client in LAN I try to mount the folder, I get this error:
Code: Select all
root@retropie:/tmp# mount -t cifs //192.168.1.2/retropie roms -o username=retropie,password=mypw,dir_mode=0777,file_mode=0777,iocharset=utf8
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Where did I wrong?

Please help!

When setting up my SAMBA system, I found I had to use the computer name, rather than the IP address, in the mount command. Never found an explanation but it worked. I was following the Debian Wiki:
https://wiki.debian.org/SambaServerSimple

Edit: please note that my server is Jessie-based, my client Stretch. Dunno if it makes any difference.
kevinthefixer
 
Posts: 55
Joined: 2018-05-05 22:30


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable