Mouse speed in Debian 9, XFCE

Kernels & Hardware, configuring network, installing services

Mouse speed in Debian 9, XFCE

Postby Kali93 » 2018-04-21 11:14

Hi guys,

I'm new here. I recently installed Debian 9 with XFCE Desktop. Changing the mouse speed in the XFCE menu doesn't make any change. I only can change the button and the wheel direction.

I already checked older posts and it might be related to some libinput xinput change that was done in Stretch. However these posts are from 2016.

Is this still an actual problem in stable?

I'm at the cell phone now and can post more info later from my PC.
Kali93
 
Posts: 5
Joined: 2018-04-21 11:04

Re: Mouse speed in Debian 9, XFCE

Postby Kali93 » 2018-04-21 17:41

I checked the pointers.xml file in ~/.config/xfce4/xfconf/xfce-perchannel-xml and when I change the settings in XFCE mouse window the new parameters are written into pointers.xml.
However my system seems to ignore it.

Kensington is my mouse:

marco@fox:~/.config/xfce4/xfconf/xfce-perchannel-xml$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Kensington Kensington Expert Mouse id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ HID 046a:0011 id=9 [slave keyboard (3)]


The parameters below are unaffected by changing the mouse acceleration:

marco@fox:~/.config/xfce4/xfconf/xfce-perchannel-xml$ xinput list-props 10
Device 'Kensington Kensington Expert Mouse':
Device Enabled (136): 1
Coordinate Transformation Matrix (138): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Accel Speed (325): 0.000000
libinput Accel Speed Default (326): 0.000000
libinput Accel Profiles Available (327): 1, 1
libinput Accel Profile Enabled (328): 1, 0
libinput Accel Profile Enabled Default (329): 1, 0
libinput Natural Scrolling Enabled (330): 0
libinput Natural Scrolling Enabled Default (331): 0
libinput Send Events Modes Available (259): 1, 0
libinput Send Events Mode Enabled (260): 0, 0
libinput Send Events Mode Enabled Default (261): 0, 0
libinput Left Handed Enabled (332): 0
libinput Left Handed Enabled Default (333): 0
libinput Scroll Methods Available (334): 0, 0, 1
libinput Scroll Method Enabled (335): 0, 0, 0
libinput Scroll Method Enabled Default (336): 0, 0, 0
libinput Button Scrolling Button (337): 2
libinput Button Scrolling Button Default (338): 2
libinput Middle Emulation Enabled (339): 0
libinput Middle Emulation Enabled Default (340): 0
Device Node (262): "/dev/input/event12"
Device Product ID (263): 1149, 4128
libinput Drag Lock Buttons (341): <no items>
libinput Horizontal Scroll Enabled (342): 1

Thanks
Kali93
 
Posts: 5
Joined: 2018-04-21 11:04

Re: Mouse speed in Debian 9, XFCE

Postby Kali93 » 2018-04-22 13:54

Does no one have any idea? :|
Kali93
 
Posts: 5
Joined: 2018-04-21 11:04

Re: Mouse speed in Debian 9, XFCE

Postby bw123 » 2018-04-22 14:28

Kali93 wrote:...
I already checked older posts and it might be related to some libinput xinput change that was done in Stretch. However these posts are from 2016.

Is this still an actual problem in stable?
...


Well, it is a problem on kde plasma for sure, I don't know about xfce. To get the mouse settings in the control panel working I installed pkg xserver-xorg-input-evdev and made /etc/X11/xorg.conf.d/50-evdev-mouse.conf

Code: Select all
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection
User avatar
bw123
 
Posts: 3392
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Mouse speed in Debian 9, XFCE

Postby Kali93 » 2018-04-22 17:31

I don't have the folder xorg.conf.d in /etc/X11

The folders in X11 are shown here:

Code: Select all
marco@fox:/etc/X11$ ll
insgesamt 76
drwxr-xr-x 2 root root  4096 Apr 19 18:58 app-defaults
-rw-r--r-- 1 root root    18 Mär 10 12:30 default-display-manager
drwxr-xr-x 6 root root  4096 Apr 19 18:58 fonts
-rw-r--r-- 1 root root 17394 Nov 23  2016 rgb.txt
drwxr-xr-x 3 root root  4096 Apr 19 18:58 xinit
drwxr-xr-x 2 root root  4096 Jul 18  2017 xkb
-rwxr-xr-x 1 root root   709 Nov 23  2016 Xreset
drwxr-xr-x 2 root root  4096 Apr 19 18:58 Xreset.d
drwxr-xr-x 2 root root  4096 Apr 19 18:58 Xresources
-rwxr-xr-x 1 root root  3517 Nov 23  2016 Xsession
drwxr-xr-x 2 root root  4096 Apr 20 14:23 Xsession.d
-rw-r--r-- 1 root root   265 Nov 23  2016 Xsession.options
drwxr-xr-x 2 root root  4096 Apr 19 18:58 xsm
-rw-r--r-- 1 root root    13 Dez  5  2016 XvMCConfig
-rw-r--r-- 1 root root   630 Mär 10 12:30 Xwrapper.config


xorg.conf.d is in /usr/share/X11/

Code: Select all
marco@fox:/usr/share/X11/xorg.conf.d$ ll
insgesamt 16
-rw-r--r-- 1 root root   92 Nov 17  2016 10-amdgpu.conf
-rw-r--r-- 1 root root 1350 Okt 14  2017 10-quirks.conf
-rw-r--r-- 1 root root  964 Jan 12  2017 40-libinput.conf
-rw-r--r-- 1 root root 2747 Jan 23  2017 70-wacom.conf


Before I'm doing something wrong and screw my mouse I wait until somebody with Debian 9 + XFCE comes up. Thank you anyway!
Kali93
 
Posts: 5
Joined: 2018-04-21 11:04

Re: Mouse speed in Debian 9, XFCE

Postby xendistar » 2018-04-27 21:11

Hi Kali93

I had mouse issues a while back but mine was related to the wheel scrolling speed, I don't believe this is your issue but if you want to have a look at the thread as there was a lot of useful information passed on by members of the forum it might help in resolving your problem.

viewtopic.php?f=5&t=123812&p=586574&hilit=xendistar#p586566

Hope it helps
xendistar
 
Posts: 100
Joined: 2010-12-29 17:52


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable