Apt-get tries to install konqueror when uninstalling Firefox

Kernels & Hardware, configuring network, installing services

Apt-get tries to install konqueror when uninstalling Firefox

Postby Lecram » 2018-05-21 17:41

Hi,

I am running debian stable 64 bit. When i tried to uninstall firefox by using apt-get it tries to install Konqueror. So i installed another browser links from the repo and then tried again it results in the same condition. This is what i get when i run apt-get remove firefox-esr
Code: Select all
Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
  libjsoncpp1
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  docbook-xml docbook-xsl dolphin4 icedove install-info kate-data katepart
  kde-baseapps-bin kde-baseapps-data kde-runtime kde-runtime-data kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdoctools konqueror libattica0.4
  libdbusmenu-qt2 libdlrestrictions1 libfam0 libgpgme++2v5 libiodbc2
  libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4
  libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
  libkonq5-templates libkonq5abi1 libkonqsidebarplugin4a libkparts4 libkpty4
  libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4
  libnepomukquery4a libnepomukutils4 libnl-3-200 libnl-route-3-200
  libntrack-qt4-1 libntrack0 libplasma3 libpolkit-qt-1-1 libqca2
  libqt4-declarative libqt4-designer libqt4-qt3support libqt4-script
  libqt4-sql libqt4-svg libsolid4 libsoprano4 libthreadweaver4 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common plasma-scriptengine-javascript sgml-data
  soprano-daemon thunderbird
Suggested packages:
  docbook docbook-dsssl docbook-defguide dbtoepub docbook-xsl-doc-html
  | docbook-xsl-doc-pdf | docbook-xsl-doc-text | docbook-xsl-doc
  docbook-xsl-saxon fop libsaxon-java libxalan2-java libxslthl-java xalan
  djvulibre-bin finger konq-plugins fam iodbc hspell
  libqt4-declarative-folderlistmodel libqt4-declarative-gestures
  libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer
  libqt4-dev media-player-info phonon-backend-vlc phonon4qt5-backend-gstreamer
  perlsgml w3-recs opensp virtuoso-minimal fonts-lyx
Recommended packages:
  icoutils sound-theme-freedesktop kfind konqueror-nsplugins kpart-webkit
  libqca2-plugins libqt4-sql-mysql | libqt4-sql-odbc | libqt4-sql-psql
  | libqt4-sql-sqlite | libqt4-sql-sqlite2 | libqt4-sql-ibase lightning
  myspell-en-us | hunspell-dictionary | myspell-dictionary
The following packages will be REMOVED:
  firefox-esr firefox-esr-l10n-bn-bd firefox-esr-l10n-bn-in
  firefox-esr-l10n-gu-in firefox-esr-l10n-hi-in firefox-esr-l10n-kn
  firefox-esr-l10n-ml firefox-esr-l10n-mr firefox-esr-l10n-ta
  firefox-esr-l10n-te iceweasel xul-ext-autofill-forms xul-ext-downthemall
  xul-ext-flashgot xul-ext-noscript xul-ext-pdf.js
The following NEW packages will be installed:
  docbook-xml docbook-xsl dolphin4 icedove install-info kate-data katepart
  kde-baseapps-bin kde-baseapps-data kde-runtime kde-runtime-data kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdoctools konqueror libattica0.4
  libdbusmenu-qt2 libdlrestrictions1 libfam0 libgpgme++2v5 libiodbc2
  libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4
  libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
  libkonq5-templates libkonq5abi1 libkonqsidebarplugin4a libkparts4 libkpty4
  libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4
  libnepomukquery4a libnepomukutils4 libnl-3-200 libnl-route-3-200
  libntrack-qt4-1 libntrack0 libplasma3 libpolkit-qt-1-1 libqca2
  libqt4-declarative libqt4-designer libqt4-qt3support libqt4-script
  libqt4-sql libqt4-svg libsolid4 libsoprano4 libthreadweaver4 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common plasma-scriptengine-javascript sgml-data
  soprano-daemon thunderbird
0 upgraded, 80 newly installed, 16 to remove and 0 not upgraded.
Need to get 113 MB of archives.
After this operation, 165 MB of additional disk space will be used.
Do you want to continue? [Y/n]


User avatar
Lecram
 
Posts: 96
Joined: 2009-06-03 08:54
Location: India


Re: Apt-get tries to install konqueror when uninstalling Fir

Postby shep » 2018-05-22 00:48

It is likely that your system requires a web browser.

One way around this is to install the web browser of your choice and then specify your choice as default
Debian has a large number of browsers that will work:
https://wiki.debian.org/WebBrowsers

See https://wiki.debian.org/HOWTO/DefaultWebBrowser. Once the default is in place, then firefox-esr will remove cleanly.
shep
 
Posts: 222
Joined: 2011-03-15 15:22

[solved] Apt-get tries to install konqueror

Postby Lecram » 2018-05-22 13:53

Thanks for the reply guys. Now I understand what the problem is.
User avatar
Lecram
 
Posts: 96
Joined: 2009-06-03 08:54
Location: India

Re: Apt-get tries to install konqueror when uninstalling Fir

Postby debiman » 2018-05-26 08:21

or just remove the meta-package that is causing all this.
User avatar
debiman
 
Posts: 2900
Joined: 2013-03-12 07:18


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable