Debian Nginx listening but not working

Kernels & Hardware, configuring network, installing services

Debian Nginx listening but not working

Postby ajokiji » 2018-06-04 21:35

Hey Guys,

Hope you are doing well.

I have a had a lot of trouble setting up Nginx for Django on Debian.

I tried probably every nginx django conf file I could find on the internet but none of them worked, I assume I cant see the forrest for the trees...

So I am running Django 2.0.4 and daphne 2.1.1.

For Daphne I am using this command:
Code: Select all
daphne -b 0.0.0.0 -e ssl:8080:privateKey=privkey.pem:certKey=ullchain.pem share_game.asgi:application -v2


And this is my Nginx Conf file, I have added a redirect to google so I can actually see that it is running:
Code: Select all
upstream tsg-backend {
  server 127.0.0.1:8080;
}

server {
  listen 159.69.13.156:80;
  server_name thesharegame.com www.thesharegame.com;
  if ($host ~* ^thesharegame\.com$) {
                rewrite ^(.*)$ https://www.thesharegame.com$1 permanent;
  }
}


server{
        listen 159.69.13.156:443 ssl http2;
        server_name thesharegame.com www.thesharegame.com;

        access_log  /var/log/nginx/tsg.log;
        error_log   /var/log/nginx/tsg.log;
       
        ssl on;
    ssl_certificate /home/tsg/fullchain.pem; # managed by Certbot
    ssl_certificate_key /home/tsg/privkey.pem; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot

    client_max_body_size    20M;

    if ($host ~* ^thesharegame\.com$) {
                rewrite ^(.*)$ https://www.thesharegame.com$1 permanent;
        }

    location / {
      ## If you use HTTPS make sure you disable gzip compression
      ## to be safe against BREACH attack.
      proxy_read_timeout      3600;
      proxy_connect_timeout   300;
      proxy_redirect          off;
      proxy_http_version 1.1;

      proxy_set_header Host $http_host;
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
      proxy_set_header Upgrade $http_upgrade;
      proxy_set_header X-Forwarded-Proto https;

      #proxy_pass http://tsg-backend;
proxy_pass https://google.com;
    }
}

Running
Code: Select all
netstat -nlp | grep 80


Code: Select all
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      14925/python3       
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      14603/nginx: master
tcp        0      0 0.0.0.0:8000            0.0.0.0:*               LISTEN      14925/python3       
tcp6       0      0 :::80                   :::*                    LISTEN      14603/nginx: master


Also,
Code: Select all
 /etc/init.d/nginx statu
s says Nginx is running.

Code: Select all
nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2018-06-04 23:10:05 CEST; 12min ago
     Docs: man:nginx(8)
  Process: 13551 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
  Process: 14601 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
  Process: 14599 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
 Main PID: 14603 (nginx)
    Tasks: 9 (limit: 4915)
   CGroup: /system.slice/nginx.service
           ├─14603 nginx: master process /usr/sbin/nginx -g daemon on; master…n;
           ├─14604 nginx: worker process
           ├─14605 nginx: worker process
           ├─14606 nginx: worker process
           ├─14607 nginx: worker process
           ├─14610 nginx: worker process
           ├─14613 nginx: worker process
           ├─14614 nginx: worker process
           └─14616 nginx: worker process

Jun 04 23:10:05 debian-share-game systemd[1]: Starting A high performance we…...
Jun 04 23:10:05 debian-share-game systemd[1]: Started A high performance web…er.
Hint: Some lines were ellipsized, use -l to show in full.


Sites-available and sites-enabled are both linked.

What am I missing? Anyone has an idea or needs more information?

I have also posted this question on stack overflow here is the link: https://stackoverflow.com/questions/506 ... ot-working

Best Regards
ajokiji
 
Posts: 1
Joined: 2018-06-04 21:28

Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable