[solved] samba server keeps on asking for password

Kernels & Hardware, configuring network, installing services

[solved] samba server keeps on asking for password

Postby milomak » 2018-06-06 19:26

it is running debian sid.

the user i am using to login with has the following in smb.conf
Code: Select all
[media]
path = /mnt/media
valid users = media
read only = no
#hosts allow = 192.168.1 127.0.0.1


when i am in macos, it logs me in automatically every time since the first time i entered in my login credentials and stated it should remember the password forever. the same holds true for when i am using windows.

however on 2 different linux machines, it constantly asks for the username and password. what could be the cause of this?
Last edited by milomak on 2018-06-13 11:22, edited 1 time in total.
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1759
Joined: 2009-06-09 22:20

Re: samba server keeps on asking for password

Postby kevinthefixer » 2018-06-07 01:13

You're going to have to be much more clear and detailed if you want help here. To start with, WHAT is using Sid? Your server, your client, what? And why in the world would you run a Samba server on a highly experimental OS? What does your server installation look like (again--details!) and what do the client machine(s) look like, including what you installed to make them Samba clients? Assuming I'm understanding you correctly that you are attempting to connect two different Linux machines as Samba clients to a Samba server running Sid, that's not at all clear. In my Linux Samba client machine I pass user and password info in the mount command, I use a GUI program to do the same in Android, and my server is now old-stable. IMHO using Sid to run any sort of server is simply asking for trouble.
kevinthefixer
 
Posts: 72
Joined: 2018-05-05 22:30

Re: samba server keeps on asking for password

Postby milomak » 2018-06-07 17:26

WHAT is using Sid? Your server, your client, what?

the server is the it that is referred to as it is the subject of the thread. for what it’s worth, both linux clients are also on sid

windows explorer - entered credentials and never asked for them again
finder - entered credentials and never asked for them again
thunar/nemo - after every login, it askes for the login credentials again even though i previously selected remember forever

And why in the world would you run a Samba server on a highly experimental OS?

it’s a media server. hardly the end of the world if something sid related.

but for the record i have been using sid for close on 15 years

What does your server installation look like (again--details!) and what do the client machine(s) look like, including what you installed to make them Samba clients?

https://wiki.debian.org/SambaServerSimple

Assuming I'm understanding you correctly that you are attempting to connect two different Linux machines as Samba clients to a Samba server running Sid

yes

that's not at all clear.

In my Linux Samba client machine I pass user and password info in the mount command, I use a GUI program to do the same in Android, and my server is now old-stable. IMHO using Sid to run any sort of server is simply asking for trouble.


i’ve been running the server for some time on sid so let’s get past that. i understand fully the risks that come with running sid. there must be something that is required in debian to keep this password saved.

and it seems to play nicely with windows and macos.
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1759
Joined: 2009-06-09 22:20

Re: samba server keeps on asking for password

Postby kevinthefixer » 2018-06-08 01:16

OK, now how are you mounting Samba shares, and where? As I said, the necessary password (and username) should be passed by the mount command.
kevinthefixer
 
Posts: 72
Joined: 2018-05-05 22:30

Re: samba server keeps on asking for password

Postby milomak » 2018-06-08 15:48

kevinthefixer wrote:OK, now how are you mounting Samba shares, and where? As I said, the necessary password (and username) should be passed by the mount command.

windows explorer - entered credentials and never asked for them again
finder - entered credentials and never asked for them again
thunar/nemo - after every login, it askes for the login credentials again even though i previously selected remember forever

i am accessing via file managers
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1759
Joined: 2009-06-09 22:20

Re: samba server keeps on asking for password

Postby kevinthefixer » 2018-06-09 01:22

Read here:
https://wiki.debian.org/SAMBAClientSetup
Try mounting your share with a command as shown then opening the mounted directory in a file manager. Remember that mount needs root priveleges. I actually use this:
https://linuxnewbieguide.org/how-to-mount-windows-or-samba-shares-permanently/
as my server is almost always running when I'm home so it's already on-line when I boot my client laptop.
kevinthefixer
 
Posts: 72
Joined: 2018-05-05 22:30

Re: samba server keeps on asking for password

Postby milomak » 2018-06-13 11:21

it was an issue with gnome-keyring on the client machines.

removed all the keyrings related to the samba server (there were a number of them) using seahorse. logged in to the samba server again and made the keyring created had no password
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1759
Joined: 2009-06-09 22:20


Return to System configuration

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable