SOLVEDHelp with mesa gallium nine install (Debian 9 Stretch)

Kernels & Hardware, configuring network, installing services

SOLVEDHelp with mesa gallium nine install (Debian 9 Stretch)

Postby lando32 » 2018-07-09 19:30

Hello all,

I've been trying to install mesa with gallium nine, and I'm trying to compile it from source. I try to run the autogen.sh script that comes with it and I get the following error:
Code: Select all
configure: error: LLVM 3.9.0 or newer is required for r600

when trying to run
Code: Select all
sudo sh autogen.sh --enable-nine --enable-llvm


autogen.sh requires LLVM 3.9 with llvm-config, so I thought that would come with llvm-3.9-dev, but whenever I delete llvm-3.8-dev and install llvm-3.9-dev, it says that I don't have llvm-config installed at all.

Any help with this is appreciated. Thanks.

Edit:

I solved the issue now, I had to go add the LLVM nightly PPA, add the archive signature key, and then update & upgrade
lando32
 
Posts: 3
Joined: 2018-07-09 19:20

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby stevepusser » 2018-07-10 01:00

I would not say that a PPA is really solving the issue at all.

Why not backport the upstream Mesa packages or rebuild the one in stretch-backports with gallium 9? Backports also has llvm-5.0 and llvm-6.0 that are necessary...I'm running Mesa 18.1.3 on a Stretch base right now, in fact.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9916
Joined: 2009-10-06 05:53

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby None1975 » 2018-07-10 12:45

lando32 wrote:I solved the issue now, I had to go add the LLVM nightly PPA, add the archive signature key, and then update & upgrade

You have not solved this problem, but only more complicated. Congratulations. You created a FrankenDebian :D
OS: Debian 9.4 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 627
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby lando32 » 2018-07-10 17:40

stevepusser wrote:I would not say that a PPA is really solving the issue at all.

Why not backport the upstream Mesa packages or rebuild the one in stretch-backports with gallium 9? Backports also has llvm-5.0 and llvm-6.0 that are necessary...I'm running Mesa 18.1.3 on a Stretch base right now, in fact.


Sorry, I meant that I added the llvm repo to my sources.list file, and then updated. I just got off ubuntu, so I'm still calling them PPAs. I'll get better eventually :D
lando32
 
Posts: 3
Joined: 2018-07-09 19:20

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby lando32 » 2018-07-10 17:54

None1975 wrote:
lando32 wrote:I solved the issue now, I had to go add the LLVM nightly PPA, add the archive signature key, and then update & upgrade

You have not solved this problem, but only more complicated. Congratulations. You created a FrankenDebian :D


Good thing that I didn't add a PPA then. I didn't know that they are an issue on Debian. I'm guessing using backports is the better option then?
lando32
 
Posts: 3
Joined: 2018-07-09 19:20

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby stevepusser » 2018-07-11 02:23

I believe that the LLVM third party repo team does a good job of making sure that their packages are compatible with the target Debian release. in contrast, PPA packagers don't build Debian packages at all; Launchpad only builds on Ubuntu platforms. They may or may not work on Debian, but have often created issues in the past.

The backports repo is maintained by Debian, see backports.org.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9916
Joined: 2009-10-06 05:53

Re: SOLVEDHelp with mesa gallium nine install (Debian 9 Stre

Postby None1975 » 2018-07-11 12:51

lando32 wrote: I'm guessing using backports is the better option then?

Yes, of course.
OS: Debian 9.4 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 627
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable